puppet

Description:A system automation and configuration management software.
License: GPL-2, Apache-2.0
Homepage:https://puppet.com/
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
6.7.2 diff - ~ ~ ~ - - - ~ ~ - - - ~
6.6.0 diff - + ~ ~ - - - ~ ~ - - - +
6.4.2 diff - + ~ ~ - - - ~ ~ - - - +
5.5.16 diff - ~ ~ ~ - - - ~ ~ - - - ~
5.5.14 diff - + ~ ~ - - - ~ ~ - - - +
4.10.12 - + ~ ~ - - - ~ ~ - - - +

USE flags

  • augeas - Enable augeas support
  • diff - Enable diff support
  • doc - Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
  • elibc_FreeBSD - ELIBC setting for systems that use the FreeBSD C library
  • emacs - Add support for GNU Emacs
  • experimental - Add patches for things in testing
  • ldap - Add LDAP support (Lightweight Directory Access Protocol)
  • minimal - Install a very minimal build (disables, for example, plugins, fonts, most drivers, non-critical features)
  • rrdtool - Enable rrdtool support
  • ruby_targets_ree18 - Build with Ruby Enterprise Edition 1.8.x (removed)
  • ruby_targets_ruby18 - Build with MRI Ruby 1.8.x (removed)
  • ruby_targets_ruby19 - Build with MRI Ruby 1.9.x
  • ruby_targets_ruby20 - Build with MRI Ruby 2.0.x
  • ruby_targets_ruby21 - Build with MRI Ruby 2.1.x
  • ruby_targets_ruby22 - Build with MRI Ruby 2.2.x
  • ruby_targets_ruby23 - Build with MRI Ruby 2.3.x
  • ruby_targets_ruby24 - Build with MRI Ruby 2.4.x
  • ruby_targets_ruby25 - Build with MRI Ruby 2.5.x
  • ruby_targets_ruby26 - Build with MRI Ruby 2.6.x
  • selinux - !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
  • shadow - Enable shadow support
  • sqlite - Add support for sqlite - embedded sql database
  • sqlite3 - Add support for sqlite3 - embedded sql database
  • test - Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
  • vim-syntax - Pulls in related vim syntax scripts
  • xemacs - Add support for XEmacs

Security Advisory

Date Severity Title
about 6 years high Puppet: Multiple vulnerabilities
about 7 years high Puppet: Multiple vulnerabilities
over 7 years high Puppet: Multiple vulnerabilities

Also available in: Atom

Thank you!