polkit

Description:Policy framework for controlling privileges for system-wide services
License: GPL-2, LGPL-2
Homepage:https://www.freedesktop.org/wiki/Software/polkit https://gitlab.freedesktop.org/polkit/polkit
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
0.120_p20220509 diff ~ ~ ~ ~ ~ - ~ ~ ~ - - ~ ~
0.120_p20220221-r1 diff ~ ~ ~ ~ ~ - ~ ~ ~ ~ - ~ ~
0.120_p20220221 ~ + + ~ ~ - ~ + + ~ - + +

USE flags

  • debug - Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
  • doc - Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
  • duktape - Use dev-lang/duktape instead of dev-lang/spidermonkey as JavaScript engine
  • examples - Install examples, usually source code
  • expat - Enable the use of dev-libs/expat for XML parsing
  • gtk - Add support for x11-libs/gtk+ (The GIMP Toolkit)
  • introspection - Add support for GObject based introspection
  • jit - Enable just-in-time compilation for improved performance. May prevent use of some PaX memory protection features in Gentoo Hardened.
  • kde - Add support for software made by KDE, a free software community
  • nls - Add Native Language Support (using gettext - GNU locale utilities)
  • pam - Add support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
  • selinux - !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
  • systemd - Use sys-apps/systemd for session tracking
  • test - Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

Security Advisory

Date Severity Title
5 months high Polkit: Local privilege escalation
12 months high polkit: Privilege escalation
almost 3 years normal polkit: Multiple vulnerabilities
over 5 years normal polkit: Heap-corruption on duplicate IDs
about 8 years high polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation
about 10 years high PolicyKit: Multiple vulnerabilities

Also available in: Atom

Thank you!