putty

Description:A Free Telnet/SSH Client
License: MIT
Homepage:https://www.chiark.greenend.org.uk/~sgtatham/putty/
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
9999 diff - - - - - - - - - - - - -
0.74 ~ + - + - - - + + - - + +

USE flags

  • doc - Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
  • gssapi - Enable support for GSSAPI (virtual/krb5)
  • gtk - Build the PuTTY client which requires x11-libs/gtk+. If disabled only the CLI tools puttygen, plink, pscp and psftp will be built
  • gtk2 - Build the PuTTY client with x11-libs/gtk+:2 instead of x11-libs/gtk+:3
  • ipv6 - Add support for IP version 6
  • kerberos - Add kerberos support

Security Advisory

Date Severity Title
over 3 years normal PuTTY: Buffer overflow
over 4 years normal PuTTY: Multiple vulnerabilities
about 7 years normal PuTTY: Multiple Vulnerabilities
over 15 years normal PuTTY: Remote code execution
almost 16 years normal PuTTY: Pre-authentication buffer overflow
about 16 years normal PuTTY: Pre-authentication arbitrary code execution

Also available in: Atom

Thank you!