rpm

Description:Red Hat Package Management Utils
License: GPL-2, LGPL-2
Homepage:https://rpm.org https://github.com/rpm-software-management/rpm
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
4.14.2.1 diff ~ ~ ~ ~ ~ - ~ ~ ~ ~ ~ ~ ~
4.14.1-r1 diff ~ ~ ~ ~ ~ - ~ ~ ~ ~ ~ ~ ~
4.14.1 + + + ~ + - ~ + + + ~ ~ +

USE flags

  • acl - Add support for Access Control Lists
  • berkdb - Add support for sys-libs/db (Berkeley DB for MySQL)
  • bzip2 - Use the bzlib compression library
  • caps - Use Linux capabilities library to control privilege
  • crypt - Add support for encryption -- using mcrypt or gpg where applicable
  • dbus - Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
  • debug - Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
  • doc - Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
  • expat - Enable the use of dev-libs/expat for XML parsing
  • gnutls - Prefer net-libs/gnutls as SSL/TLS provider (ineffective with USE=-ssl)
  • lua - Enable Lua scripting support
  • lzma - Support for LZMA (de)compression algorithm
  • nls - Add Native Language Support (using gettext - GNU locale utilities)
  • pcre - Add support for Perl Compatible Regular Expressions
  • perl - Add optional support/bindings for the Perl language
  • python - Add optional support/bindings for the Python language
  • python_single_target_python2_6 - Build for Python 2.6 only
  • python_single_target_python2_7 - Build for Python 2.7 only
  • python_single_target_python3_5 - Build for Python 3.5 only
  • python_single_target_python3_6 - Build for Python 3.6 only
  • python_single_target_python3_7 - Build for Python 3.7 only
  • python_targets_python2_6 - Build with Python 2.6 (removed)
  • python_targets_python2_7 - Build with Python 2.7
  • python_targets_python3_5 - Build with Python 3.5
  • python_targets_python3_6 - Build with Python 3.6
  • python_targets_python3_7 - Build with Python 3.7
  • readline - Enable support for libreadline, a GNU line-editing library that almost everyone wants
  • ruby - Add support/bindings for the Ruby language
  • selinux - !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
  • sqlite - Add support for sqlite - embedded sql database
  • ssl - Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
  • tcl - Add support the Tcl language
  • test - Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
  • xattr - Add support for extended attributes (filesystem-stored metadata)
  • zlib - Add support for zlib (de)compression
  • zstd - Enable support for ZSTD compression

Security Advisory

Date Severity Title
about 1 year normal RPM: Multiple vulnerabilities
over 7 years high RPM: Multiple vulnerabilities
about 13 years normal RPM: Buffer overflow

Also available in: Atom

Thank you!