Bug #861

Инсталлятор CLD-15.12 неверно определяет возможность UEFI-загрузки

Added by Илья Петров almost 4 years ago. Updated almost 4 years ago.

Status:New Start:02/22/2016
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

В системе три жёстких диска, из них два MBR и один (основной, с которого производится старт, подключен к нулевому гнезду мат.платы и по умолчанию определён как загрузочный) - GPT. На диске уже установлены ОС Gentoo и Windows. Разметка диска:

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Единицы: sectors по 1 * 512 = 512 байт
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Тип метки диска: gpt
Идентификатор диска: 7EC228C6-FBE6-49C5-BE40-2C7F7E0686BF

Устр-во        Start Конец Секторы   Size Тип
/dev/sda1       2048      6143      4096     2M BIOS boot             <-- переменные uefi
/dev/sda2       6144   1048575   1042432   509M EFI System            <-- /boot с ядром и загрузчиком gentoo
                                                                          и запускалкой windows
/dev/sda3    1048576  51380223  50331648    24G Linux своп
/dev/sda4   51380224 261095423 209715200   100G Linux root (x86-64)   <-- Gentoo root
/dev/sda5  261095424 261357567    262144   128M Microsoft reserved
/dev/sda6  261357568 364378111 103020544  49.1G Microsoft basic data  <-- Windows root
/dev/sda7  364378112 574230527 209852416 100.1G Linux filesystem      <-- Calculate root

Использовалась графическая установка. На этапе разметки диска был выбран вариант "Использовать существующую разметку диска", на следующем этапе "Точки монтирования" появилась пустая таблица с точками монтирования. Вручную был добавлен раздел /dev/sda3 как swap и /dev/sda7 как /. Была снята галочка "Использовать UUID", явно установлена галочка "UEFI-загрузка", был явно выбран загрузочный диск /dev/sda и без изменения оставлен I/O планировщик (пустое поле). Нажатие кнопки "далее" привело к появлению сообщения "MBR не используется вместе с UEFI-загрузчиком"

History

Updated by Илья Петров almost 4 years ago

Провёл ещё немного исследований: данная проблема проявляется только при выборе загрузочного диска (также при указании --mbr off при установке через cl-install), т.о. проблема остаётся только в не совсем внятном интерфейсе и в невозможности отказаться от установки загрузчика при использовании gui.

Updated by Mikhail Hiretsky almost 4 years ago

При установки в UEFI загрузочный диск не используется, так как для установки используются загрузчики в EFI разделе. В GUI нужно просто не менять настройки загрузочного диска (оставить как есть).

Also available in: Atom PDF

Thank you!