Support #827

Сегфолты Firefox

Added by Андрей Волков about 4 years ago. Updated over 3 years ago.

Status:New Start:11/05/2015
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

Доброго времени суток! На CLDX 15 x86_64 регулярно падает Firefox (выдает ошибку сегментирования):

/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
console.error:
[CustomizableUI]
Custom widget with id loop-button does not return a valid node
console.error:
[CustomizableUI]
Custom widget with id loop-button does not return a valid node
console.error:
[CustomizableUI]
NotFoundError: Node was not found -- :1152
WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15412:21
/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
NOT SANDBOXED
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
[fresh 6953] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 6953] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
Vector smash protection is enabled.
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
NOT SANDBOXED
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
[fresh 7052] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 7052] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
Vector smash protection is enabled.
Performance warning: Async animation disabled because frame size (9457, 401) is bigger than the viewport (1537, 801) or the visual rectangle (9457, 401) is larger than the max allowable value (17895698) [div]
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
NOT SANDBOXED
[fresh] [warning] ppb_var_var_to_utf8, 'var' is not a string, (0)
[fresh 7107] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 7107] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
Vector smash protection is enabled.
/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
NOT SANDBOXED
[fresh 7129] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 7129] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
Vector smash protection is enabled.
Ошибка сегментирования
[NPAPI 7126] ###!!! ABORT: Aborting on channel error.: file /var/calculate/tmp/portage/www-client/firefox-42.0/work/firefox-42.0/ipc/glue/MessageChannel.cpp, line 1768

Как избавиться от этой проблемы?

History

Updated by Андрей Волков about 4 years ago

Окончание вывода:

[NPAPI 7126] ###!!! ABORT: Aborting on channel error.: file /var/calculate/tmp/portage/www-client/firefox-42.0/work/firefox-42.0/ipc/glue/MessageChannel.cpp, line 1768

Updated by Сергей Федотов about 4 years ago

NPAPI используется Adobe Flash Player. Отключите флеш и будет вам счастье. Благо на многих сайтах уже есть нативная поддержка (аудио/видео/web api) К концу 2016 Мозилла прекращает поддержку NPAPI.

Updated by Андрей Волков about 4 years ago

Сергей Федотов wrote:

Отключите флеш и будет вам счастье.

Сергей, благодарю за ответ. Отключение флеша не помогло, Firefox по-прежнему падает:

/usr/share/themes/MurrinaEalm/gtk-2.0/gtkrc:47: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
console.error:
[CustomizableUI]
Custom widget with id loop-button does not return a valid node
console.error:
[CustomizableUI]
Custom widget with id loop-button does not return a valid node
console.error:
[CustomizableUI]
NotFoundError: Node was not found -- :1152
Ошибка сегментирования

Updated by Alexander Pilipenko almost 4 years ago

тоже постоянно крашится, вот конец вывода перед падением (собран с флагом debug для дополнительных подробностей вывода) http://pastebin.calculate-linux.ru/ru/show/11481

Updated by Андрей Волков over 3 years ago

Предлагаю объединить ветку с этой: http://www.calculate-linux.ru/issues/851 (судя по выводу, причина сбоя, вероятно, одна и та же - проблемы с библиотеками /usr/lib64/firefox/libxul.so и /lib64/libc.so.6)

Updated by Adrien Duck over 3 years ago

Андрей Волков wrote:

Предлагаю объединить ветку с этой: http://www.calculate-linux.ru/issues/851 (судя по выводу, причина сбоя, вероятно, одна и та же - проблемы с библиотеками /usr/lib64/firefox/libxul.so и /lib64/libc.so.6)

Хорошая идея. У Вас проблемы с firefox-bin?

Updated by Андрей Волков over 3 years ago

Adrien Daugabel wrote:

У Вас проблемы с firefox-bin?

Не только. Помимо www-client/firefox и www-client/firefox-bin, падают, как оказалось, также www-client/chromium и www-client/qupzilla, а также некоторые приложения из среды KDE 5 (во всех случаях причина падения - ошибка сегментации). Полагаю, что первопричина падений заключается в некорректной работе библиотеки sys-libs/glibc.

Also available in: Atom PDF

Thank you!