Bug #812

Не грузится KDE с ядром 4.1.10

Added by Андрей Тимираев about 4 years ago. Updated about 4 years ago.

Status:New Start:10/08/2015
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

После последнего обновления перестала грузится ДЕ (показывает логотип, а дальше мигание логотипа несколько раз и после мигание курсора на черном экране, так же мигает лампочка num lock). Причина как то связана с ядром 4.1.10, так как со старым ядром система грузится нормально. boot отдельным разделом.

darkprof@darkhost ~ $ uname -a
Linux darkhost 3.18.20-calculate #1 SMP PREEMPT Thu Aug 13 16:30:47 UTC 2015 x86_64 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux
darkprof@darkhost ~ $

darkprof@darkhost ~ $ lsmod
Module Size Used by
ecryptfs 70147 0
nvidia 10500559 49
drm 233198 3 nvidia
bnep 10212 2
bluetooth 277957 5 bnep
rfkill 14499 2 bluetooth
crc16 1231 1 bluetooth
ext2 60790 1
mbcache 8067 1 ext2
vboxnetadp 17670 0
vboxnetflt 15250 0
vboxdrv 318127 2 vboxnetadp,vboxnetflt
vhba 8066 0
snd_hda_codec_hdmi 36247 4
uvcvideo 69801 0
snd_usb_audio 118806 1
videobuf2_vmalloc 2568 1 uvcvideo
videobuf2_memops 1727 1 videobuf2_vmalloc
videobuf2_core 33843 1 uvcvideo
snd_usbmidi_lib 19307 1 snd_usb_audio
v4l2_common 3842 1 videobuf2_core
videodev 109684 3 uvcvideo,v4l2_common,videobuf2_core
snd_rawmidi 17590 1 snd_usbmidi_lib
joydev 9343 0
snd_seq_device 4764 1 snd_rawmidi
ppdev 5554 0
snd_hda_codec_realtek 56243 1
snd_hda_codec_generic 50374 1 snd_hda_codec_realtek
kvm_amd 47402 0
kvm 276305 1 kvm_amd
snd_hda_intel 21451 5
snd_hda_controller 16850 1 snd_hda_intel
k10temp 2828 0
hwmon 2738 1 k10temp
snd_hda_codec 86987 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep 5948 2 snd_usb_audio,snd_hda_codec
snd_pcm 75936 5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer 17685 1 snd_pcm
snd 55388 24 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
sp5100_tco 4760 0
acpi_cpufreq 6746 0
i2c_piix4 8600 0
parport_pc 18564 1
wmi 7579 0
shpchp 24273 0
i2c_core 19902 5 drm,i2c_piix4,nvidia,v4l2_common,videodev
processor 22988 7 acpi_cpufreq
button 4300 0
crc32c_generic 1480 1
btrfs 769389 3
xor 10960 1 btrfs
zlib_deflate 20220 1 btrfs
raid6_pq 90630 1 btrfs
ata_generic 3274 0
pata_acpi 3163 0
pata_atiixp 4587 0
ohci_pci 2880 0
ohci_hcd 28116 1 ohci_pci
r8169 66684 0
mii 3739 1 r8169
uvesafb 21713 1
ipv6 302420 58
sunrpc 170043 0
darkprof@darkhost ~ $

darkprof@darkhost ~ $ lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:05.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 1)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 570 Rev. 2] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)

> 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

emerge.log (1.6 MB) Андрей Тимираев, 10/16/2015 07:16 pm

Xorg.0.log (22.8 KB) Андрей Тимираев, 10/17/2015 04:44 pm

Xorg.0.log (27.5 KB) Сергей Петрович, 10/20/2015 06:19 pm

errorsx (1.5 KB) Сергей Петрович, 10/20/2015 06:19 pm

History

Updated by Андрей Тимираев about 4 years ago

darkprof@darkhost ~ $ eix sys-kernel/calculate-sources
[?] sys-kernel/calculate-sources [1]
     Available versions:  
     (3.12.48) ~3.12.48^bs
     (3.14.54) ~3.14.54^bs
     (3.18.22) ~3.18.22^bs
     (4.1.10) 4.1.10^bs{tbz2}
     (4.2.3) ~4.2.3^bs
       {build firmware minimal symlink themes vmlinuz}
     Installed versions:  3.18.20(3.18.20)^bs{tbz2}(21:42:36 13.08.2015)(firmware minimal symlink themes vmlinuz -build) 4.1.10(4.1.10)^bs{tbz2}(14:30:21 06.10.2015)(firmware minimal symlink themes vmlinuz -build)
     Homepage:            http://www.calculate-linux.org
     Description:         Calculate Linux kernel image

[1] "calculate" /var/lib/layman/calculate
darkprof@darkhost ~ $

Updated by Андрей Тимираев about 4 years ago

SafeMode тоже не грузится.

Updated by Андрей Тимираев about 4 years ago

Похоже немного другая проблема, так как на старом ядре

darkprof@darkhost ~ $ eix nvidia-drivers                  
[I] x11-drivers/nvidia-drivers
     Available versions:  [M]96.43.23^msd [M]~96.43.23-r1(0/96)^msd [M]173.14.39^msd [M]~173.14.39-r1(0/173)^msd 304.128^msd ~304.128-r1(0/304)^msd 340.93^msd{tbz2} ~340.93-r1(0/340)^msd 346.96^msd ~346.96-r1(0/346)^msd 352.41^msd ~352.41-r1(0/352)^msd 355.11^msd{tbz2} ~355.11-r2(0/355)^msd {+X acpi custom-cflags gtk gtk2 gtk3 multilib pax_kernel (+)tools uvm KERNEL="FreeBSD linux"}
     Installed versions:  355.11^msd{tbz2}(20:42:11 23.09.2015)(X multilib -acpi -gtk2 -gtk3 -pax_kernel -tools -uvm KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA Accelerated Graphics Driver

darkprof@darkhost ~ $ 

Но да, конфликт в видеодрайвере (даже в консоль не войдешь, все моргает и клава долго отзывается). Снес nvidia и система загрузилать в консоль (подгружать nouveau не стал).

Updated by Андрей Тимираев about 4 years ago

После удаления и установкой с помощью emerge --usepkg-exclude 'x11-drivers/nvidia-drivers' nvidia-drivers под новым ядром помогло, спасибо большое.

Updated by Alexander Tratsevskiy about 4 years ago

Такое ощущение, что это проскочил баг и создался бинарный пакет. Такое было с ati-drivers, там мы удаляли файл.

Updated by Alexander Tratsevskiy about 4 years ago

Сейчас доступно для обновления ядро 4.2.3. Проблема осталась?

Updated by Sergey Vasin about 4 years ago

Alexander Tratsevskiy wrote:

Сейчас доступно для обновления ядро 4.2.3. Проблема осталась?

Подтверждаю, аналогичная проблема. Видео - intel
  1. uname -a
    Linux azimut 4.2.3-calculate #1 SMP PREEMPT Fri Oct 16 10:41:54 MSK 2015 x86_64 Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz GenuineIntel GNU/Linux

Updated by Сергей Петрович about 4 years ago

это капец! после обновы система упала. я так трясся за её жизнь, ибо только начал жить этим миром)
экран моргает, в консольный режим не зайти по ctrl+alt+f2, на короткое время только появляется и всё.
думал что сам накосячил, переставил систему-обновил и всё труп
на ядре 4,2,3

Updated by Vasilii B about 4 years ago

Сергей Петрович wrote:

это капец! после обновы система упала. я так трясся за её жизнь, ибо только начал жить этим миром)
экран моргает, в консольный режим не зайти по ctrl+alt+f2, на короткое время только появляется и всё.
думал что сам накосячил, переставил систему-обновил и всё труп
на ядре 4,2,3

В таких ситуациях очень помогает резервный канал связи... ssh, например, но иногда и он не спасает.

Появляется ли окно GRUB с выбором варианта загрузки?
Если появляется, тогда внизу подсказка как попасть в редактирование параметров загрузки (е - латинская буква).

там находишь строку с параметрами загрузки (обычно самая длинная строка), дописываешь туда "nox"

должно запуститься без Х.

заходишь в систему.
От имени рута запускаешь:
телепаю-телепаю-телепаю... нет, всё таки не могу нателепать, что за видеокарта... выше есть пример для nvidia, но что-то подсказывает, что есть там ATI и/или Intel...

emerge @x11-module-rebuild
reboot

Меня этот набор выручал пару раз, когда забывал после обновления модули подновить, последний раз не помогло:
http://www.calculate-linux.ru/issues/815

Updated by Mikhail Hiretsky about 4 years ago

Приложите /var/log/emerge.log

Updated by Андрей Тимираев about 4 years ago

После обновы до 4.2.3 не грузится в графический режим ни с одним ядром (включая старое 3.18.20 ,для каждого отдельно переустанавливаю нвидиа 340.49 и 355.11 с --usepkg-exclude и меняю eselect kernel set ... Позже попробую загрузиться с nox

Updated by Андрей Тимираев about 4 years ago

Без иксов грузится и ssh тоже работает. Вот мой emerge.log

Updated by Vasilii B about 4 years ago

Андрей Тимираев wrote:

После обновы до 4.2.3 не грузится в графический режим ни с одним ядром (включая старое 3.18.20 ,для каждого отдельно переустанавливаю нвидиа 340.49 и 355.11 с --usepkg-exclude и меняю eselect kernel set ... Позже попробую загрузиться с nox

мне помогло описанное тут решение (мною же и описанное), но возможно шаги 1-3(4) - будут лишними в Вашем случае:
http://www.calculate-linux.ru/issues/815

Обновился "синькой" на 4.2.3 - 5 минут - полёт нормальный.

vasilii@BW ~ $ uname -a
Linux BW 4.2.3-calculate #1 SMP PREEMPT Fri Oct 16 22:57:09 CEST 2015 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux

Updated by Андрей Тимираев about 4 years ago

мне помогло описанное тут решение (мною же и описанное), но возможно шаги 1-3(4) - будут лишними в Вашем случае:
http://www.calculate-linux.ru/issues/815

Выполнял с 4 пункта - не помогло

Updated by Андрей Тимираев about 4 years ago

Вообщем начал копать в чем дело и нашел вот это:
sudo cat /var/log/Xorg.0.log | grep EE
[ 2401.826] Current Operating System: Linux darkhost 4.2.3-calculate #1 SMP PREEMPT Fri Oct 16 15:36:18 YEKT 2015 x86_64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 2402.404] (EE) evdev: USB USB Keyboard: Unable to query fd: Inappropriate ioctl for device
[ 2402.417] (EE) PreInit returned 2 for "USB USB Keyboard"
[ 2402.419] (EE) evdev: A4TECH USB Device: Unable to query fd: Invalid argument
[ 2402.432] (EE) PreInit returned 2 for "A4TECH USB Device"
[ 2414.513] (EE) Server terminated successfully (0). Closing log file.
Ничего про видео нет. Пробовал запустить с nouveau - то же самое. Показывается заставка ночного неба на котором должна отображаться загрузка kde, но она не появляется.

Updated by Андрей Тимираев about 4 years ago

xinit xterm отработал удачно. Установил xfce и удачно запустил (glxgears выдает фпс как с проприетарным драйвером). К сожалению проверить gnome нет места. Что то не так с кедами...

Updated by Сергей Петрович about 4 years ago

Vasilii B wrote:

Сергей Петрович wrote:

это капец! после обновы система упала. я так трясся за её жизнь, ибо только начал жить этим миром)
экран моргает, в консольный режим не зайти по ctrl+alt+f2, на короткое время только появляется и всё.
думал что сам накосячил, переставил систему-обновил и всё труп
на ядре 4,2,3

В таких ситуациях очень помогает резервный канал связи... ssh, например, но иногда и он не спасает.


Появляется ли окно GRUB с выбором варианта загрузки?
Если появляется, тогда внизу подсказка как попасть в редактирование параметров загрузки (е - латинская буква).


там находишь строку с параметрами загрузки (обычно самая длинная строка), дописываешь туда "nox"


должно запуститься без Х.


заходишь в систему.
От имени рута запускаешь:
телепаю-телепаю-телепаю... нет, всё таки не могу нателепать, что за видеокарта... выше есть пример для nvidia, но что-то подсказывает, что есть там ATI и/или Intel...


emerge @x11-module-rebuild
reboot


Меня этот набор выручал пару раз, когда забывал после обновления модули подновить, последний раз не помогло:
http://www.calculate-linux.ru/issues/815

Телепатить не нужно)
у меня ноут интел+ати, но дискретка не работала, так как я не ставил драйвер, а точнее у меня не выходит уже недели 3... по мануалам итд.
К сожалению ваш способ мне не помог.
Пробовал разные варианты манипуляций с этим делом и осмелюсь предположить что дело не в ядре. А сделал так: чистая установка(то есть с нуля), жмём обновление, программа обновляет всё по списку и когда спрашивает установить пакеты и ядро, тупо игнорим. Запускаем консоль и по очереди ставим пакеты которые нам предлагают обновить. Геморно но ради пробы сделал, ядро я не ставил. перезагруз и система в ауте. Разработчики подскажите что делать, не бежать же от этого))

Updated by Андрей Тимираев about 4 years ago

Сергей Петрович писал:

перезагруз и система в ауте.

У вас kde? Если кеды, то попробуйте зайти в консольном режиме и запустите, скажем xfce

Updated by Сергей Петрович about 4 years ago

Андрей Тимираев wrote:

Сергей Петрович писал:

перезагруз и система в ауте.

У вас kde? Если кеды, то попробуйте зайти в консольном режиме и запустите, скажем xfce

Да на кедах работал. startx повторяет ситуацию. вываливаетсяв ошибку, чуть позже выложу
а startxfce4 -команда не найдена. Вроде всё правильно, их там и не должно быть, так как кеды стоят.
Поставил CLDX, обновился нормально, работает на новом ядре

Updated by Mikhail Hiretsky about 4 years ago

Попробуйте пересобрать небинарные kde-base/kdelibs.

Updated by Андрей Тимираев about 4 years ago

Попробуйте пересобрать небинарные kde-base/kdelibs.

Откатился обратно на CLD и выполнил sudo emerge --usepkg-exclude 'kde-base/kdelibs' kdelibs. Не помогло

Updated by Сергей Петрович about 4 years ago

Небыло времени сюда забегать, но проблема
так и осталась, как и обещал выкладываю логи:
errosx это лог из консоли при запуске startx.
если сделать так: emerge xterm то после startx выскакивает псевдо рабочий стол с тремя окошками из консолей. если во всех написать exit то выкинет обратно в консольный режим с ошибками х сервера, но уже без ошибки xterm

Updated by Андрей Тимираев about 4 years ago

Сергей Петрович wrote:

Небыло времени сюда забегать, но проблема
так и осталась, как и обещал выкладываю логи:
errosx это лог из консоли при запуске startx.
если сделать так: emerge xterm то после startx выскакивает псевдо рабочий стол с тремя окошками из консолей. если во всех написать exit то выкинет обратно в консольный режим с ошибками х сервера, но уже без ошибки xterm

Более того, xfce тоже стартует. Можете временно его использовать (предварительно установив через emerge)

Updated by Сергей Петрович about 4 years ago

Более того, xfce тоже стартует. Можете временно его использовать (предварительно установив через emerge)

не страшно, у меня 2 hdd, один для испытаний. правда и на основном система то полетела. пока сижу на плазме5, выпилил xfce и поставил. Но там ужас, программы перемешались и интерфейс частично. Но пользоваться можно. Я подожду, кде 4 пока больше нравится. Надеюсь на лучшее

Updated by Vasilii B about 4 years ago

не знаю, вдруг поможет кому.
Опять таки всё работает:
Версия набора ПО KDE - 4.14.13
Версия ОС - Linux 4.2.3-calculate
x11-drivers/nvidia-drivers-355.11-r2 (GeForce GTX 760)
Файл подкачки отсутствует совсем...

Должно быть всё по состоянию на сегодня по профилю [23] distros:CLD/amd64 *
Фрагмент make.conf/custom

EMERGE_DEFAULT_OPTS="${EMERGE_DEFAULT_OPTS} --jobs=9 --load-average=16 --keep-going=y --with-bdeps=y --complete-graph --autounmask-write"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev synaptics"
ABI_X86="64"

/etc/portage/package.use/custom
sys-kernel/calculate-sources -minimal
app-admin/conky USE="X apcupsd curl debug eve hddtemp imlib iostats lua lua-cairo lua-imlib math moc mpd nano-syntax ncurses portmon rss thinkpad truetype vim-syntax weather-metar weather-xoap xmms2"
media-sound/pulseaudio USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gtk ipv6 native-headset ofono-headset orc ssl tcpd udev webrtc-aec zeroconf"
=media-sound/pulseaudio-7.0-r1 abi_x86_32
=virtual/libintl-0-r2 abi_x86_32
=x11-libs/gdk-pixbuf-2.32.1 abi_x86_32

Может быть поможет кому, возможно где-то тут камень и зарыт...
например в sys-kernel/calculate-sources -minimal

Updated by Сергей Петрович about 4 years ago

надо попробовать. Может быть что то еше разработчики подскажут?

Updated by Андрей Тимираев about 4 years ago

Вообщем моя проблема решилась. После смены профиля обратно на distros:CLD/amd64, замены Xfce на Plasma в /etc/profile.env и запуска через startx я заметил ошибку об отсутствии startkde. Он был установлен kde-base/kdebase-startkde и удачно запущен. Возможно повлияла пересборка sudo emerge --usepkg-exclude 'kde-base/kdelibs' kdelibs.

Updated by Сергей Петрович about 4 years ago

а мне не помогло(

Updated by Андрей Тимираев about 4 years ago

Сергей Петрович wrote:

а мне не помогло(

Еще я подправил make.conf/custom
EMERGE_DEFAULT_OPTS="${EMERGE_DEFAULT_OPTS} --jobs=9 --load-average=16 --keep-going=y --with-bdeps=y --complete-graph --autounmask-write"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev synaptics"
ABI_X86="64"

Какая видеокарта в вашем случае я не знаю

Updated by Сергей Петрович about 4 years ago

еще раз всё повторил.
/etc/portage/package.use/custom вообще оказался путсым. добавил туда то что тут советовали
VIDEO_CARDS="intel" у меня интел
не работает. вываливаются ошибки

sega@calculate ~ $ startx
xauth:  file /home/sega/.serverauth.7362 does not exist

X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.2.1-calculate x86_64 Gentoo
Current Operating System: Linux calculate 4.2.3-calculate #1 SMP PREEMPT Sat Oct 3 21:00:45 UTC 2015 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.3-calculate root=UUID=94a9dbd2-4dc8-427a-8055-bd47bf0d54a0 ro zswap.enabled=1 
zswap.compressor=lz4 zswap.max_pool_percent=30 video=1366x768 elevator=bfq calculate=video:intel splash=silent,theme:calculate 
console=tty1 quiet nox
Build Date: 24 September 2015  08:20:49AM

Current version of pixman: 0.32.8
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 20 19:45:42 2015
(==) Using config file: "/etc/X11/xorg.conf" 
(==) Using config directory: "/etc/X11/xorg.conf.d" 
(==) Using system config directory "/usr/share/X11/xorg.conf.d" 
/etc/X11/xinit/xinitrc: line 59: twm: ĸoмaндa нe нaйдeнa
/etc/X11/xinit/xinitrc: line 60: xclock: ĸoмaндa нe нaйдeнa
/etc/X11/xinit/xinitrc: line 63: exec: xterm: нe нaйдeн
xinit: connection to X server lost

waiting for X server to shut down (EE) Server terminated successfully (0). Closing log f

Updated by Vasilii B about 4 years ago

Сергей Петрович wrote:

еще раз всё повторил.

> VIDEO_CARDS="intel" у меня интел

не работает. вываливаются ошибки
[...]

это в /etc/portage/make.conf/custom лучше вписать, а из /etc/portage/package.use/custom - удалить...

потом ещё может быть полезным сделать:
eix-sync
emerge -uDNa @world
revdep-rebuild

Кстати, "--autounmask-write" ключ, в результате применения которого emerge автоматически подготавливает обновления для файлов в глубинах /etc/portage/*/custom, но для их применения надо запустить etc-update, просмотреть все предлагаемые изменения и применить желаемые.

Updated by Vasilii B about 4 years ago

Андрей Тимираев wrote:

Сергей Петрович wrote:

а мне не помогло(

Еще я подправил make.conf/custom
EMERGE_DEFAULT_OPTS="${EMERGE_DEFAULT_OPTS} --jobs=9 --load-average=16 --keep-going=y --with-bdeps=y --complete-graph --autounmask-write"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev synaptics"
ABI_X86="64"


Какая видеокарта в вашем случае я не знаю

а рекомендуют параметр "--jobs=X", где Х=(число ядер ЦП)+1, т.е. у меня установлено 9, т.к. у меня в ПК установлен 8 ядрёный ЦП, а ABI_X86="64" - т.к. 64 битный процессор то, а иметь 32+64 битных пакетов нет особого желания, хотя для некоторых пакетов надо 32 бит...

Updated by Сергей Петрович about 4 years ago

Спасибо за помощь, надоела нервотрёпка эта. Бросил.
Но по сути момент не приятный, пользователь качает рабочий образ системы, но после обновления получает не рабочую систему.

Updated by Alexander Tratsevskiy about 4 years ago

Сергей Петрович wrote:

Спасибо за помощь, надоела нервотрёпка эта. Бросил.
Но по сути момент не приятный, пользователь качает рабочий образ системы, но после обновления получает не рабочую систему.

И тогда вы просто загружаетесь в предыдущую систему. Если используете второй раздел для установки конечно.

Updated by Сергей Петрович about 4 years ago

Alexander Tratsevskiy wrote:

Сергей Петрович wrote:

Спасибо за помощь, надоела нервотрёпка эта. Бросил.
Но по сути момент не приятный, пользователь качает рабочий образ системы, но после обновления получает не рабочую систему.

И тогда вы просто загружаетесь в предыдущую систему. Если используете второй раздел для установки конечно.

Хорошо, а какой смысл тогда сидеть на "старых пакетах"?
я скачал еженедельный срез, проблемы нет.

Updated by Alexander Tratsevskiy about 4 years ago

Сергей Петрович wrote:

Alexander Tratsevskiy wrote:

Сергей Петрович wrote:

Спасибо за помощь, надоела нервотрёпка эта. Бросил.
Но по сути момент не приятный, пользователь качает рабочий образ системы, но после обновления получает не рабочую систему.

И тогда вы просто загружаетесь в предыдущую систему. Если используете второй раздел для установки конечно.

Хорошо, а какой смысл тогда сидеть на "старых пакетах"?
я скачал еженедельный срез, проблемы нет.

Смотря что называть старыми пакетами. Я привёл пример, как можно (и нужно) устанавливать свежий Stage и не получать проблем при обновлении.

Updated by Vasilii B about 4 years ago

Alexander Tratsevskiy wrote:

Сергей Петрович wrote:

Alexander Tratsevskiy wrote:

Сергей Петрович wrote:

Спасибо за помощь, надоела нервотрёпка эта. Бросил.
Но по сути момент не приятный, пользователь качает рабочий образ системы, но после обновления получает не рабочую систему.

И тогда вы просто загружаетесь в предыдущую систему. Если используете второй раздел для установки конечно.

Хорошо, а какой смысл тогда сидеть на "старых пакетах"?
я скачал еженедельный срез, проблемы нет.

Смотря что называть старыми пакетами. Я привёл пример, как можно (и нужно) устанавливать свежий Stage и не получать проблем при обновлении.

ушли от темы далеко и надолго.

Linux, пока ещё остаётся своеобразной ОС, а что именно использовать, как и какой дистрибутив использовать - выбор каждого.

Остановился на калькуляторе, команде разработчиков большое спасибо за их работу.

Also available in: Atom PDF

Thank you!