Bug #803

cl-builder-update

Added by Алексей Тихонов almost 4 years ago. Updated almost 4 years ago.

Status:New Start:09/14/2015
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

http://imglink.ru/show-image.php?id=ac03375d6de9c180ad3640a4d46cbba7
обновление собранного не предусмотрено ?

History

Updated by Alexander Tratsevskiy almost 4 years ago

Сперва нужно подготовить образ при помощи cl-builder-prepare. Только загружаться уже нужно не в builder режиме.

Updated by Алексей Тихонов almost 4 years ago

Alexander Tratsevskiy wrote:

Сперва нужно подготовить образ при помощи cl-builder-prepare. Только загружаться уже нужно не в builder режиме.

образ был собран новым билдером в виртуалке - > установлен вместо того в котором собирал (проверить же надо) -> выполнил :
сl-builder-prepare --source /путь/до/*.iso -d /dev/sdb1 --id cli 

далее :
сl-builder-update

результат на скрине :)
  • calculate,distros,cli,portage на bitbucket в качестве теста перед переводом своей сборки на новые утилиты на своём gitolite-gentoo ... то есть сборка с --branch без проблем а вот обновить такое уже не судьба ... хм , чистый cls тоже не захотел(( (cl-assemble не думает над таким) )

ps. в общем новый билдер понравился .. особенно cl-builder-restore (в assemble конечно не было с эти проблем , но тут удобней) ... молодцы .

Updated by Алексей Тихонов almost 4 years ago

Alexander Tratsevskiy

если в системе поменять профиль допустим на cls то всё нормально работает ... то есть захотел я обновить свой iso , меняю профиль -> обновляю iso :)
http://imglink.ru/show-image.php?id=561cd0502ff685459e3065db1095a935

Updated by Алексей Тихонов almost 4 years ago

спасибо , работает :)
зы. в бэта2 сl-builder-* потерялись ... пришлось 9999 накатить :)

Updated by Алексей Тихонов almost 4 years ago

не буду создавать новую тему ... с лайва не создаётся пользователь :

calculate useradd[3721]: Authentication service cannot retrieve authentication info
calculate useradd[3721]: failed adding user 'guest', data deleted

*не создаётся только с лайва , после установки проблем нет

Updated by Mikhail Hiretsky almost 4 years ago

Образ свой или наш stage? В какой момент не создаётся: во время загрузки или вручную?

Updated by Алексей Тихонов almost 4 years ago

Mikhail Hiretsky wrote:

Образ свой или наш stage? В какой момент не создаётся: во время загрузки или вручную?

и во время загрузки и вручную (если собираю в cl-assemble проблемы нет)
образ свой (утилит то 3.4 пока нету в stage)

Updated by Mikhail Hiretsky almost 4 years ago

А на основе чего сборка CSS/CLS?

Updated by Алексей Тихонов almost 4 years ago

Mikhail Hiretsky wrote:

А на основе чего сборка CSS/CLS?

CLS ... вопрос снят (нашел проблему у себя ... спешка)

Updated by Алексей Тихонов almost 4 years ago

cl-utils-3.4.0_beta5(да и на 3,4,0,2) , при выполнении сl-update --*-world добавляются все пакеты профиля
  • не зависимо от rebuild,merge,update .. что довольно таки плохо например если меняется gcc .
    Раньше при сl-update --rebuild-world в world попадали пакеты только из base .. то есть обновил/очистил и пересобрал ~400 пакетов и потом уже добавил остальные пакеты профиля (зачем лишнее канпелять ?)

Also available in: Atom PDF

Thank you!