Bug #726

Конфликт при обновлении системы.

Added by Павел Митенков over 4 years ago. Updated over 4 years ago.

Status:New Start:03/15/2015
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Calculate Linux Desktop KDE Spent time: -
Target version:-
Votes: 2

Description

не могу обновить недавно установленную систему

 * Вычисление зависимостей ...                                                                                          [ ok ]
[ebuild   R    ] virtual/libintl-0-r1  ABI_X86="32* (64) (-x32)" 0 KiB
[binary     U  ] virtual/libiconv-0-r2 [0-r1] ABI_X86="(64) (-32) (-x32)" 15 KiB
[ebuild   R    ] media-libs/libdvdcss-1.2.13-r1:1.2  USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 331 KiB
[ebuild   R    ] net-libs/libasyncns-0.8-r3  USE="-debug -doc" ABI_X86="32* (64) (-x32)" 334 KiB
[ebuild   R    ] dev-libs/libaio-0.3.110  USE="-static-libs {-test}" ABI_X86="32* (64) (-x32)" 42 KiB
[ebuild   R    ] dev-libs/libdaemon-0.14-r2  USE="-doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 333 KiB
[binary     U  ] sys-kernel/linux-firmware-20150206 [20141009] USE="-savedconfig" 44701 KiB
[ebuild   R    ] dev-util/cppunit-1.13.2-r2  USE="-doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 932 KiB
[binary   R    ] kde-base/oxygen-icons-4.14.3:4/4.14  USE="(-aqua) -sources% (-bindist%)" 33561 KiB
[binary     U  ] sys-kernel/linux-headers-3.18 [3.16] 772 KiB
[binary     U  ] dev-lang/tcl-8.5.17 [8.5.15-r1] USE="threads -debug" ABI_X86="(64) (-32) (-x32)" 3844 KiB
[binary     U  ] media-fonts/droid-113-r4 [113-r3] USE="X" 4291 KiB
[binary     U  ] media-fonts/liberation-fonts-2.00.1-r1 [2.00.0-r1] USE="X -fontforge" 2042 KiB
[ebuild   R    ] media-libs/sbc-1.3  USE="-static-libs" ABI_X86="32* (64) (-x32)" 241 KiB
[binary     U  ] app-admin/eselect-1.4.4 [1.4.3] USE="-doc -emacs -vim-syntax" 90 KiB
[binary     U  ] dev-python/setuptools-12.0.1 [7.0] USE="{-test}" PYTHON_TARGETS="python2_7 (-pypy) (-pypy3) -python3_3 -python3_4" 455 KiB
[ebuild   R    ] dev-libs/popt-1.16-r2  USE="nls -static-libs" ABI_X86="32* (64) (-x32)" 687 KiB
[ebuild   R    ] app-text/iso-codes-3.57  LINGUAS="en ru -af -am -ar -as -ast -az -be -bg* -bn -bn_IN -br -bs -byn -ca -crh -cs -cy -da -de* -dz -el -eo -es* -et -eu -fa -fi -fo -fr* -ga -gez -gl -gu -haw -he -hi -hr -hu -hy -ia -id -is -it* -ja -ka -kk -km -kn -ko -kok -ku -lt -lv -mi -mk -ml -mn -mr -ms -mt -nb -ne -nl -nn -nso -oc -or -pa -pl* -ps -pt* -pt_BR* -ro* -rw -si -sk -sl -so -sq -sr -sr@latin -sv -sw -ta -te -th -ti -tig -tk -tl -tr -tt -tt@iqtelif -ug -uk* -ve -vi -wa -wal -wo -xh -zh_CN -zh_HK -zh_TW -zu" 3686 KiB
[ebuild   R    ] media-gfx/exiv2-0.24-r1:0/13  USE="nls xmp zlib -contrib -doc -examples -static-libs" ABI_X86="(64) (-32) (-x32)" LINGUAS="ru -de* -es* -fi -fr* -pl* -sk" 4527 KiB
[ebuild   R    ] sys-devel/flex-2.5.39-r1  USE="nls -static {-test}" ABI_X86="32* (64) (-x32)" 1316 KiB
[ebuild   R    ] sys-libs/tdb-1.3.0-r1  USE="-python" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7" 468 KiB
[ebuild   R    ] net-dns/dnsmasq-2.72  USE="dbus dhcp ipv6 nls -auth-dns -conntrack -dhcp-tools -dnssec -idn -lua -script (-selinux) -static -tftp" LINGUAS="-de* -es* -fi -fr* -id -it* -no -pl* -pt_BR* -ro*" 444 KiB
[binary     U  ] dev-lang/tk-8.5.17 [8.5.15] USE="threads truetype (-aqua) -debug {-test} -xscreensaver" 2498 KiB
[ebuild  N     ] dev-libs/libltdl-2.4.4  USE="-static-libs" ABI_X86="32 (64) (-x32)" 936 KiB
[binary     U  ] sys-devel/libtool-2.4.4:2 [2.4.2-r1:2] USE="-vanilla (-static-libs%) (-test%)" ABI_X86="(-32%) (-64%*) (-x32%)" 0 KiB
[blocks b      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.4)
[ebuild  N     ] dev-libs/libevdev-1.3  USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[binary  N     ] x11-drivers/xf86-input-synaptics-1.8.1  213 KiB
[ebuild   R    ] app-text/hunspell-1.3.3  USE="ncurses nls readline -static-libs" LINGUAS="en ru -af -bg* -ca -cs -cy -da -de* -el -eo -es* -et -fo -fr* -ga -gl -he -hr -hu -ia -id -is -it* -km -ku -lt -lv -mk -ms -nb -nl -nn -pl* -pt* -pt_BR* -ro* -sk -sl -sq -sv -sw -tn -uk* -zu" 963 KiB
[ebuild   R    ] dev-libs/iniparser-3.1-r1  USE="-doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 39 KiB
[ebuild   R    ] dev-libs/libev-4.15-r1  USE="-static-libs" ABI_X86="32* (64) (-x32)" 502 KiB
[ebuild  N     ] x11-proto/dri2proto-2.8-r1  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] x11-proto/glproto-1.4.17  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] x11-proto/xf86driproto-2.1.1-r1  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] x11-proto/dri3proto-1.0  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] x11-proto/presentproto-1.0  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] app-text/recode-3.6_p20-r1  USE="nls -static-libs" ABI_X86="32* (64) (-x32)" 2044 KiB
[ebuild   R    ] net-libs/neon-0.30.1:0/27  USE="nls ssl zlib -doc -expat -gnutls -kerberos -libproxy -pkcs11 -static-libs" ABI_X86="(64) (-32) (-x32)" LINGUAS="ru -cs -de* -fr* -ja -nn -pl* -tr -zh_CN" 891 KiB
[binary     U  ] dev-python/pyzmq-14.4.1 [14.4.0] USE="-doc -examples -green {-test}" PYTHON_TARGETS="python2_7 -python3_3 -python3_4" 365 KiB
[ebuild   R    ] sys-apps/dmapi-2.2.12-r1  USE="-static-libs" ABI_X86="32* (64) (-x32)" 359 KiB
[ebuild   R    ] app-arch/snappy-1.1.2-r1  USE="-static-libs" ABI_X86="32* (64) (-x32)" 1451 KiB
[binary     U  ] dev-python/lxml-3.4.2 [3.4.1] USE="threads -beautifulsoup3 -doc -examples" PYTHON_TARGETS="python2_7 -python3_3 -python3_4" 877 KiB
[ebuild     U  ] dev-libs/protobuf-2.5.0-r2:0/8 [2.5.0-r1:0/8] USE="-emacs -examples -java -python -source -static-libs -vim-syntax" ABI_X86="32%* (64%*) (-x32)" PYTHON_TARGETS="python2_7" 1824 KiB
[ebuild   R    ] app-i18n/enca-1.14-r2  USE="recode -doc" ABI_X86="32* (64) (-x32)" 548 KiB
[ebuild   R    ] app-office/libreoffice-l10n-4.3.5.2  USE="-offlinehelp" LINGUAS="en ru -af -am -ar -as -ast -be -bg* -bn -bn_IN -bo -br -brx -bs -ca -ca_valencia -cs -cy -da -de* -dgo -dz -el -en_GB -en_ZA -eo -es* -et -eu -fa -fi -fr* -ga -gd -gl -gu -he -hi -hr -hu -id -is -it* -ja -ka -kk -km -kmr_Latn -kn -ko -kok -ks -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl* -pt* -pt_BR* -ro* -rw -sa_IN -sat -sd -si -sid -sk -sl -sq -sr -sr_Latn -ss -st -sv -sw_TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk* -uz -ve -vi -xh -zh_CN -zh_TW -zu" 1627 KiB
[ebuild   R    ] net-libs/gnutls-3.3.10-r2  USE="crywrap cxx nls zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" LINGUAS="en -cs -de* -fi -fr* -it* -ms -nl -pl* -sv -uk* -vi -zh_CN" 6029 KiB
[binary   R    ] net-misc/vpnc-0.5.3_p527-r1  USE="gnutls -resolvconf (-selinux) (-bindist%)" 110 KiB
[ebuild   R    ] app-text/ghostscript-gpl-9.10-r2  USE="X cups dbus djvu gtk -bindist -idn -static-libs" LINGUAS="-de* -ja -ko -zh_CN -zh_TW" 30465 KiB
[ebuild   R    ] app-admin/system-config-printer-gnome-1.4.3-r1  USE="-gnome-keyring" LINGUAS="ru -ar -as -bg* -bn -bn_IN -br -bs -ca -cs -cy -da -de* -el -en_GB -es* -et -fa -fi -fr* -gu -he -hi -hr -hu -hy -id -is -it* -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl* -pt* -pt_BR* -ro* -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -uk* -vi -zh_CN -zh_TW" PYTHON_TARGETS="python2_7" 872 KiB
[binary     U  ] net-print/cups-filters-1.0.66 [1.0.53] USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 845 KiB
[ebuild     U  ] dev-libs/librevenge-9999::mva [0.0.2::gentoo] USE="-doc (-test%)" ABI_X86="(64) (-32) (-x32)" 0 KiB
[binary   R    ] media-video/ffmpeg-1.2.6-r1  USE="X aac alsa amr bzip2 cpudetection encode faac hardcoded-tables iconv ieee1394 jpeg2k mp3 network openal pulseaudio sdl speex theora threads truetype v4l vaapi vdpau vorbis x264 xvid zlib -aacplus (-altivec) -bluray -cdio (-celt) -debug -doc -examples -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -jack -libass -libcaca -libsoxr -libv4l -modplug (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -static-libs {-test} -twolame (-vis) -vpx (-bindist%)" ABI_X86="(64) (-32) (-x32)" CPU_FLAGS_X86="3dnow 3dnowext avx mmx mmxext ssse3" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 5654 KiB
[binary   R    ] media-libs/opencv-2.4.9:0/2.4  USE="eigen ffmpeg gtk ieee1394 jpeg jpeg2k openexr opengl openmp png python qt4 threads tiff v4l -cuda -doc -examples -gstreamer (-ipp) -java -libav% -opencl -pch -testprograms (-vtk) -xine" PYTHON_TARGETS="python2_7" 7193 KiB
[ebuild   R    ] kde-base/kde-l10n-4.14.3:4/4.14  USE="handbook (-aqua)" LINGUAS="ru -ar -bg* -bs -ca -ca@valencia -cs -da -de* -el -en_GB -es* -et -eu -fa -fi -fr* -ga -gl -he -hi -hr -hu -ia -id -is -it* -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl* -pt* -pt_BR* -ro* -sk -sl -sr -sv -tr -ug -uk* -wa -zh_CN -zh_TW" 0 KiB
[binary   R    ] media-libs/mlt-0.9.0  USE="dv ffmpeg gtk kde kdenlive melt qt4 quicktime sdl vdpau vorbis xml -compressed-lumas -debug -frei0r -jack -libav% -libsamplerate -lua -python -rtaudio -ruby -xine" CPU_FLAGS_X86="mmx sse sse2" 3066 KiB
[ebuild     U  ] sys-auth/polkit-kde-agent-0.99.1:4 [0.99.0-r1:4] USE="(-aqua) -debug -minimal%" LINGUAS="ru -ar% -bs% -ca -ca@valencia -cs -da -de* -el% -en_GB -eo -es* -et -fi -fr* -ga -gl -hr -hu -is -it* -ja -kk% -km -lt -mai -mr% -ms -nb -nds -nl -pa -pl% -pt* -pt_BR* -ro* -sk -sl% -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug% -uk* -vi% -zh_CN% -zh_TW" 38 KiB
[ebuild   R    ] net-libs/libktorrent-1.3.1:4  USE="handbook (-aqua) -debug {-test}" LINGUAS="ru -ar -ast -be -bg* -bs -ca -ca@valencia -cs -da -de* -el -en_GB -eo -es* -et -eu -fi -fr* -ga -gl -hi -hne -hr -hu -is -it* -ja -km -ku -lt -lv -ms -nb -nds -nl -nn -oc -pl* -pt* -pt_BR* -ro* -se -si -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -tr -ug -uk* -zh_CN -zh_TW" 843 KiB
[ebuild   R    ] net-wireless/bluedevil-2.0_rc1:4  USE="(-aqua) -debug" LINGUAS="ru -ar -bs -ca -ca@valencia -cs -da -de* -el -en_GB -eo -es* -et -eu -fa -fi -fr* -ga -gl -hu -it* -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl* -pt* -pt_BR* -ro* -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk* -zh_CN -zh_TW" 159 KiB
[ebuild   R    ] kde-misc/kde-gtk-config-2.2.1:4  USE="(-aqua) -debug" LINGUAS="ru -bs -ca -ca@valencia -cs -da -de* -el -es* -et -eu -fi -fr* -ga -gl -hu -id -it* -ja -kk -km -lt -mr -nb -nds -nl -pl* -pt* -pt_BR* -ro* -sk -sl -sv -uk* -zh_CN -zh_TW" 85 KiB
[ebuild   R    ] kde-misc/kscreen-1.0.2.1:4  USE="(-aqua) -debug {-test}" LINGUAS="ru -bs -ca -cs -da -de* -el -es* -et -fi -fr* -ga -gl -hu -it* -lt -mr -nl -pt* -pt_BR* -ro* -sk -sl -sv -tr -ug -uk* -zh_CN -zh_TW" 78 KiB
[ebuild   R    ] kde-misc/plasma-nm-0.9.3.4:4  USE="modemmanager (-aqua) -debug -openconnect" LINGUAS="ru -ar -bs -ca -ca@valencia -cs -da -de* -el -en_GB -eo -es* -et -fa -fi -fr* -ga -gl -hr -hu -is -it* -ja -km -lt -lv -mai -mr -ms -nb -nds -nl -nn -pa -pl* -pt* -pt_BR* -ro* -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk* -zh_CN -zh_TW" 516 KiB
[blocks B      ] app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]" is blocking dev-libs/libevdev-1.3, x11-proto/dri3proto-1.0, x11-proto/presentproto-1.0, x11-proto/glproto-1.4.17, x11-proto/dri2proto-2.8-r1, x11-proto/xf86driproto-2.1.1-r1)
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/libltdl-2.4.4)
 * 60 пакетов будет установлено, 174179 KiB будет загружено
    >=x11-proto/glproto-1.4.16-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-proto/glproto-1.4.16-r1:=[abi_x86_64(-)]) необходим для (media-libs/mesa-10.3.7-r1:0/0::gentoo, установлен)
    x11-proto/glproto необходим для (x11-drivers/xf86-video-ati-7.5.0:0/0::gentoo, установлен)

  (dev-libs/libltdl-2.4.4:0/0::gentoo, пакет будет установлен из ebuild-сценария) зависимость пакета
    dev-libs/libltdl:0 необходим для (media-gfx/imagemagick-6.9.0.3:0/6.9.0.3::gentoo, установлен)
    dev-libs/libltdl:0 необходим для (sys-devel/libtool-2.4.4:2/2::gentoo, будет установлен бинарный пакет)
    dev-libs/libltdl:0 необходим для (media-sound/pulseaudio-5.0-r4:0/0::gentoo, установлен)
    dev-libs/libltdl:0 необходим для (dev-libs/redland-1.0.16:0/0::gentoo, установлен)

  (app-emulation/emul-linux-x86-baselibs-20140508-r12:0/0::gentoo, установлен) зависимость пакета
    >=app-emulation/emul-linux-x86-baselibs-10.0-r1 необходим для (net-print/cndrvcups-capt-2.00-r2:0/0::calculate, установлен)
    ~app-emulation/emul-linux-x86-baselibs-20140508 необходим для (app-emulation/emul-linux-x86-xlibs-20140508:0/0::gentoo, установлен)

  (x11-proto/xf86driproto-2.1.1-r1:0/0::gentoo, пакет будет установлен из ebuild-сценария) зависимость пакета
    x11-proto/xf86driproto необходим для (x11-libs/glamor-0.6.0-r1:0/0::gentoo, установлен)
    >=x11-proto/xf86driproto-2.1.0 необходим для (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, установлен)
    >=x11-proto/xf86driproto-2.1.1-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-proto/xf86driproto-2.1.1-r1:=[abi_x86_64(-)]) необходим для (media-libs/mesa-10.3.7-r1:0/0::gentoo, установлен)
    x11-proto/xf86driproto необходим для (x11-drivers/xf86-video-nouveau-1.0.11:0/0::gentoo, установлен)
    x11-proto/xf86driproto необходим для (x11-drivers/xf86-video-ati-7.5.0:0/0::gentoo, установлен)
    x11-proto/xf86driproto необходим для (x11-drivers/xf86-video-intel-2.99.917:0/0::gentoo, установлен)
    >=x11-proto/xf86driproto-2.1.1-r1:0/0=[abi_x86_64(-)] необходим для (media-libs/mesa-10.3.7-r1:0/0::gentoo, установлен)

  (dev-libs/libevdev-1.3:0/0::gentoo, пакет будет установлен из ebuild-сценария) зависимость пакета
    >=dev-libs/libevdev-0.4 необходим для (x11-drivers/xf86-input-synaptics-1.8.1:0/0::gentoo, будет установлен бинарный пакет)
    dev-libs/libevdev необходим для (x11-drivers/xf86-input-evdev-2.9.1:0/0::gentoo, установлен)

History

Updated by Iurii Blokhin over 4 years ago

Какие были размаскировки, изменения в use-флагах, изменения make.conf?

Updated by Андрей Долгов over 4 years ago

У меня похожая картина:

(x11-base/xorg-server-1.15.2-r2:0/1.15.2::gentoo, пакет будет установлен из ebuild-сценария) зависимость пакета
x11-base/xorg-server:0/1.15.2= необходим для (x11-drivers/xf86-video-vesa-2.3.3:0/0::gentoo, установлен)

Iurii Blokhin wrote:

Какие были размаскировки, изменения в use-флагах, изменения make.conf?

Не было никаких.

Updated by Павел Митенков over 4 years ago

в make.conf только добавлена строчка
CFLAGS="-O2 -march=amdfam10 -pipe"

package.keywords


games-util/steam-launcher ~amd64
media-sound/clementine ~amd64
www-client/opera ~amd64

package.use


media-sound/amarok lastfm mtp ofa
media-sound/clementine ayatana  mtp lastfm
#sys-fs/eudev gudev

Also available in: Atom PDF

Thank you!