Bug #681

pam & systemd

Added by Alexander Pilipenko about 5 years ago. Updated about 5 years ago.

Status:New Start:09/10/2014
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

При установленном systemd некоторые приложения могут некорректно работать (например NetworkManager), для исправления нужно изменить шаблон /var/lib/layman/calculate/profiles/templates/3.1/2_ac_install_merge/sys-auth/pambase/system-auth

*** /var/lib/layman/calculate/profiles/templates/3.1/2_ac_install_merge/sys-auth/pambase/system-auth    2014-06-19 03:19:53.645392779 +0400
--- system-auth    2014-09-10 02:32:45.523825861 +0400
***************
*** 46,48 ****
--- 46,51 ----
  #?pkg(sys-auth/pam_client)!=&&pkg(sys-apps/calculate-client)!=||pkg(sys-apps/calculate-server)!=#
  session    optional     pam_ldap.so
  #pkg#
+ #?pkg(sys-apps/systemd)!=#
+ session    optional     pam_systemd.so
+ #pkg#

необходимость данной строки описана в http://wiki.gentoo.org/wiki/Systemd#systemd-logind_.26_pam_systemd

History

Updated by Mikhail Hiretsky about 5 years ago

Спасибо. Правку добавили в оверлей.

Also available in: Atom PDF

Thank you!