Bug #634

Update. Missing dbus flag

Added by Aydar Kamalov almost 6 years ago. Updated over 5 years ago.

Status:New Start:01/31/2014
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:-
Votes: 0

Description

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.7.4:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)
(dependency required by "sys-auth/polkit-kde-agent-0.99.0-r1" [installed])
(dependency required by "kde-base/kdelibs-4.12.1" [binary])
(dependency required by "kde-base/kdesu-4.12.1" [binary])
(dependency required by "kde-base/khelpcenter-4.12.1" [binary])

History

Updated by Mikhail Hiretsky almost 6 years ago

Оверлей обновлен?

Updated by Aydar Kamalov almost 6 years ago

да, загрузился cld13.11 и сделал eix-sync

Updated by Mikhail Hiretsky almost 6 years ago

А обновляли какой командой?

Updated by Aydar Kamalov almost 6 years ago

emerge world -vuDN

Updated by Mikhail Hiretsky almost 6 years ago

Приложите полный вывод emerge.

Updated by Андрей Гуляев almost 6 years ago

emerge world -vuDN

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.7.4:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)
(dependency required by "kde-misc/openofficeorg-thumbnail-1.0.0-r2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Updated by Mikhail Hiretsky almost 6 years ago

Попробуйте пересобрать kde-misc/openofficeorg-thumbnail.

Updated by Андрей Гуляев almost 6 years ago

emerge -1 kde-misc/openofficeorg-thumbnail

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.7.4:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)
(dependency required by "kde-misc/openofficeorg-thumbnail-1.0.0-r2" [binary])
(dependency required by "kde-misc/openofficeorg-thumbnail" [argument])

Updated by Aydar Kamalov almost 6 years ago

Андрей Гуляев wrote:

- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)

попробуйте обновить портежи
eix-sync

Updated by Илья Семенов over 5 years ago

У меня такая же проблема:

# emerge --update --newuse --deep --with-bdeps=y @world

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.7.4:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)
- dev-qt/qtgui-4.8.5-r1::gentoo (Missing IUSE: dbus)
(dependency required by "sys-auth/polkit-kde-agent-0.99.0-r1" [binary])
(dependency required by "sys-auth/polkit-0.112-r1" [binary])
(dependency required by "sys-auth/consolekit-0.4.6" [binary])
(dependency required by "sys-auth/pambase-20120417-r3" [binary])
(dependency required by "sys-libs/pam-1.1.6-r2" [installed])

eix-sync запускал только что.

Aydar Kamalov, у тебя получилось решить проблему?

Updated by Артём Власов over 5 years ago

Посмотрите мой баг: http://www.calculate-linux.org/issues/640
Там объяснена причина ошибки и описано временное решение проблемы.

Also available in: Atom PDF

Thank you!