Bug #475

обновление portage и eix-0.26.3-r1::calculate на x86 ломает базу данных eix

Added by brother appsee about 7 years ago. Updated about 7 years ago.

Status:New Start:08/23/2012
Priority:Urgent Due date:
Assignee:- % Done:

0%

Category:Calculate Linux Scratch Spent time: -
Target version:-
Votes: 8

Description

обновил на 2х разных машинах с CLS-i686 сегодня portage и eix-0.26.3-r1::calculate - на обеих машинах пропала база eix, видит только оверлей Calculate, ни дерева, ни других оверлеев не видно. Чистка кэшей portage и eix, как и пересборка / откатка на раннюю версию eix - не помогает.

emerge --info одной из машин: https://paste.lugons.org/show/3099/

подтвердите баг.

History

Updated by brother appsee about 7 years ago

Проблему удалось решить физическим удалением /usr/portage, всех кешей, удаление установленной с оверлея app-portage/eix-0.26.3-r1 - далее emerge --sync, установка стабильного на текущий момент eix-0.25.5:

http://www.calculate-linux.ru/packages/app-portage/eix
http://packages.gentoo.org/package/app-portage/eix

и eix заработал. Насколько я понял, всё у меня поломалось на 2х машинах из-за нестабильного eix-0.26.3-r1 (отмеченного так на packages.calculate и packages.gentoo). Возможно он по ошибке стал размаскирован в оверлее?

Updated by Mikhail Hiretsky about 7 years ago

Вы пробовали выполнить eix-update команду?

Updated by brother appsee about 7 years ago

Mikhail Hiretsky wrote:

Вы пробовали выполнить eix-update команду?

раз 20. В случае если ни у кого не подтверждается, постараюсь воспроизвести и понять в чем именно проблема, т.к. одновременно на 2х машинах - не очень случайность, хотя)

Updated by Александр Афанасин about 7 years ago

У меня также, после сегодняшнего обновления eix. Не находит пакеты, на xfce 32-битном :(

brother appsee wrote:

Mikhail Hiretsky wrote:

Вы пробовали выполнить eix-update команду?

раз 20. В случае если ни у кого не подтверждается, постараюсь воспроизвести и понять в чем именно проблема, т.к. одновременно на 2х машинах - не очень случайность, хотя)

Updated by Артемий Рублев about 7 years ago

brother appsee wrote:

Проблему удалось решить физическим удалением /usr/portage, всех кешей, удаление установленной с оверлея app-portage/eix-0.26.3-r1 - далее emerge --sync, установка стабильного на текущий момент eix-0.25.5:
и eix заработал. Насколько я понял, всё у меня поломалось на 2х машинах из-за нестабильного eix-0.26.3-r1 (отмеченного так на packages.calculate и packages.gentoo). Возможно он по ошибке стал размаскирован в оверлее?

Подтверждаю синдром, диагноз и рецепт. Сам поломал 2 машины (cld-12.0.2-x86) и указанным способом вылечил.

Updated by Elena FRISON about 7 years ago

Стрелку вверх поставила ещё вчера, а сегодня подтверждаю баг на словах: eix поломался после обновления на свежеустановленной из последнего среза 32-битной CLS, ещё до добавления пакетов. Спасибо brother appsee за рецепт, но хочется исправления.

Updated by Евгений Уразов about 7 years ago

Elena Gavrilova wrote:

Стрелку вверх поставила ещё вчера, а сегодня подтверждаю баг на словах: eix поломался после обновления на свежеустановленной из последнего среза 32-битной CLS, ещё до добавления пакетов. Спасибо brother appsee за рецепт, но хочется исправления.

аналогично.

Updated by Mikhail Hiretsky about 7 years ago

Вы пробовали обновлять портежи командой eix-sync ?

Updated by Виктор Кустов about 7 years ago

подтверждаю баг.
app-portage/eix-0.26.3-r2 та же петрушка.

Updated by brother appsee about 7 years ago

Mikhail Hiretsky wrote:

Вы пробовали обновлять портежи командой eix-sync ?

Михаил, тащемта суть такова для x86:

Что не помогает после обновления app-portage/eix до 0.26.3-r1::calculate:

... Удаление obsolete cache, предложенный после обновления.
... eix-update
... eix-sync

Что помогает:

... ручное удаление кеша
... откатка до app-portage/eix-0.25.5
... eix-sync

Подтверждено уже более 15 пользователями, хотя не все любезно согласились зайти и подтвердить баг.

Updated by brother appsee about 7 years ago

brother appsee wrote:

Что не помогает после обновления app-portage/eix до 0.26.3-r1::calculate

та же история с 0.26.3-r2::calculate

вот лог обновления и что происходит: http://overlays.in/calculate/eix.txt

кстати, все, кто подтвердил баг - используют x86 архитектуру

Updated by Elena FRISON about 7 years ago

brother appsee wrote:

та же история с 0.26.3-r2::calculate

Да, вторая ревизия ничем не помогла.

Also available in: Atom PDF

Thank you!