GLSA 200903-33: FFmpeg: Multiple vulnerabilities

Title:FFmpeg: Multiple vulnerabilities
Bugs: #231831, #231834, #245313, #257217, #257381


Multiple vulnerabilities in FFmpeg may lead to the remote execution of arbitrary code or a Denial of Service.


FFmpeg is a complete solution to record, convert and stream audio and video. gst-plugins-ffmpeg is a FFmpeg based gstreamer plugin which includes a vulnerable copy of FFmpeg code. Mplayer is a multimedia player which also includes a vulnerable copy of the code.

Affected packages

Package Vulnerable Unaffected Architecture(s)
media-video/ffmpeg < 0.4.9_p20090201 >= 0.4.9_p20090201 All supported architectures
media-plugins/gst-plugins-ffmpeg < 0.10.5 >= 0.10.5 All supported architectures
media-video/mplayer < 1.0_rc2_p28450 >= 1.0_rc2_p28450 All supported architectures


Multiple vulnerabilities were found in FFmpeg:

  • astrange reported a stack-based buffer overflow in the str_read_packet() in libavformat/psxstr.c when processing .str files (CVE-2008-3162).
  • Multiple buffer overflows in libavformat/utils.c (CVE-2008-4866).
  • A buffer overflow in libavcodec/dca.c (CVE-2008-4867).
  • An unspecified vulnerability in the avcodec_close() function in libavcodec/utils.c (CVE-2008-4868).
  • Unspecified memory leaks (CVE-2008-4869).
  • Tobias Klein repoerted a NULL pointer dereference due to an integer signedness error in the fourxm_read_header() function in libavformat/4xm.c (CVE-2009-0385).


A remote attacker could entice a user to open a specially crafted media file, possibly leading to the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.


There is no known workaround at this time.


All FFmpeg users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-0.4.9_p20090201"

All gst-plugins-ffmpeg users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-ffmpeg-0.10.5"

All Mplayer users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=media-video/mplayer-1.0_rc2_p28450"



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!