GLSA 200803-14: Ghostscript: Buffer overflow

Title:Ghostscript: Buffer overflow
Bugs: #208999


A stack-based buffer overflow has been discovered in Ghostscript, allowing arbitrary code execution.


Ghostscript is a suite of software based on an interpreter for PostScript and PDF.

Affected packages

Package Vulnerable Unaffected Architecture(s)
app-text/ghostscript-esp < 8.15.4-r1 >= 8.15.4-r1 All supported architectures
app-text/ghostscript-gpl < 8.61-r3 >= 8.61-r3 All supported architectures
app-text/ghostscript-gnu < 8.60.0-r2 >= 8.60.0-r2 All supported architectures


Chris Evans (Google Security) discovered a stack-based buffer overflow within the zseticcspace() function in the file zicc.c when processing a PostScript file containing a long "Range" array in a .seticcscpate operator.


A remote attacker could exploit this vulnerability by enticing a user to open a specially crafted PostScript file, which could possibly lead to the execution of arbitrary code or a Denial of Service.


There is no known workaround at this time.


All Ghostscript ESP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/ghostscript-esp-8.15.4-r1"

All Ghostscript GPL users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.61-r3"

All Ghostscript GNU users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.60.0-r2"



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!