openpgp-keys-philiphazel-20220416.ebuild

Download (543 Bytes)

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="OpenPGP keys used by Philip Hazel"
HOMEPAGE="http://quercite.dx.am/"
SRC_URI="https://github.com/PhilipHazel.gpg -> ${P}.asc"
S="${WORKDIR}"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"

src_install() {
	local files=( ${A} )

	insinto /usr/share/openpgp-keys
	newins - philiphazel.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
}

Thank you!