spice-gtk

Description:Set of GObject and Gtk objects for connecting to Spice servers and a client GUI
License: LGPL-2.1
Homepage:https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
9999 diff - - - - - - - - - - - - -
0.37-r2 diff ~ ~ ~ - ~ - - ~ ~ - - ~ ~
0.35 ~ + ~ - ~ - - ~ ~ - - ~ +

USE flags

  • cairo - Enable support for the cairo graphics library
  • dbus - Support for desktop integration such as automounting and other APIs exposed by your DE via D-Bus
  • doc - Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
  • gnome - Add GNOME support
  • gstaudio - Using gstreamer backend as audio decodec support
  • gstreamer - Add support for media-libs/gstreamer (Streaming media)
  • gstvideo - Using gstreamer backend as video decodec support
  • gtk3 - Build the spice client (spicy), requires x11-libs/gtk+:3
  • introspection - Add support for GObject based introspection
  • kde - Add support for software made by KDE, a free software community
  • libressl - Use dev-libs/libressl instead of dev-libs/openssl when applicable (see also the ssl useflag)
  • lz4 - Enable support for lz4 compression (as implemented in app-arch/lz4)
  • mjpeg - Enable builtin mjpeg video decoder
  • policykit - Enable sys-auth/polkit support for the usbredir acl helper
  • pulseaudio - Add support for PulseAudio sound server
  • python - Add optional support/bindings for the Python language
  • python_single_target_python2_6 - Build for Python 2.6 only
  • python_single_target_python2_7 - Build for Python 2.7 only
  • python_single_target_python3_4 - Build for Python 3.4 only
  • python_targets_python2_6 - Build with Python 2.6 (removed)
  • python_targets_python2_7 - Build with Python 2.7
  • python_targets_python3_4 - Build with Python 3.4
  • sasl - Add support for the Simple Authentication and Security Layer
  • smartcard - Enable smartcard support
  • static-libs - Build static versions of dynamic libraries as well
  • usbredir - Use sys-apps/usbredir to redirect USB devices to another machine over TCP
  • vala - Enable bindings for dev-lang/vala
  • webdav - Support for folder-sharing between guest and client using net-libs/phodav

Security Advisory

Date Severity Title
about 1 year normal spice-gtk: Remote code execution
over 5 years high polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation
over 5 years high spice-gtk: Privilege escalation

Also available in: Atom

Thank you!