Bug #667

не запускается графический установщик в cld 13.19

Added by Олег Бахарев about 5 years ago.

Status:New Start:07/29/2014
Priority:High Due date:
Assignee:- % Done:

0%

Category:Calculate Linux Desktop Spent time: -
Target version:-
Votes: 0

Description

Графический установщик CLD 13.19 не запускается, выдавая ошибку 111 "в соединении отказано". При попытке запустить calculate-core выскакивает исключение Python (ошибка возникает на стадии генерации сертификата):

calculate-core   |Traceback (most recent call last):
calculate-core   |  File "/usr/sbin/cl-core-2.7", line 28, in <module>
calculate-core   |    sys.exit(main())
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/func.py", line 1664, in wrapper
calculate-core   |    return func(*args,**kwargs)
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/cl_server.py", line 121, in main
calculate-core   |    port, args.bootstrap_user_name)
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/bootstrap.py", line 84, in init
calculate-core   |    create_server_cert(cert, key, cert_path, args, port)
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/bootstrap.py", line 122, in create_server_cert
calculate-core   |    cert_cmd.check_server_certificate(cert,key,cert_path,args,port,auto=True)
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/cert_cmd.py", line 139, in check_server_certificate
calculate-core   |    cert = makeCert(req, pkey, name)
calculate-core   |  File "/usr/lib/python2.7/site-packages/calculate/core/server/create_cert.py", line 143, in makeCert
calculate-core   |    cert.add_ext(X509.new_extension('subjectKeyIdentifier', 'hash'))
calculate-core   |  File "/usr/lib/python2.7/site-packages/M2Crypto/X509.py", line 29, in new_extension
calculate-core   |    raise ValueError('value must be precomputed hash')
calculate-core   |ValueError: value must be precomputed hash              [ !! ]
calculate-core   | * ERROR: calculate-core failed to start

Ошибка замечена в CLD 13.19 и в последнем на данный момент срезе 20140725

снимок1.png (272.8 KB) Олег Бахарев, 07/29/2014 09:33 pm

Also available in: Atom PDF

Thank you!