GLSA 201701-18: Python: Multiple vulnerabilities

Title:Python: Multiple vulnerabilities
Bugs: #531002, #585910, #585946


Multiple vulnerabilities have been found in Python, the worst of which could lead to arbitrary code execution.


Python is an interpreted, interactive, object-oriented programming language.

Affected packages

Package Vulnerable Unaffected Architecture(s)
dev-lang/python < 3.4.5 >= 2.7.12 All supported architectures


Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.


A remote attacker could entice a user to open a specially crafted index file using Python’s dumbdbm module, possibly resulting in execution of arbitrary code with the privileges of the process.

A remote attacker could entice a user to process a specially crafted input stream using Python’s zipimporter module, possibly allowing attackers to cause unspecified impact.

A man in the middle attacker could strip out the STARTTLS command without generating an exception on the Python SMTP client application, preventing the establishment of the TLS layer.


There is no known workaround at this time.


All Python 2 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.12:2.7"

All Python 3 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.4.5:3.4"



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!