GLSA 201503-11: OpenSSL: Multiple vulnerabilities

Title:OpenSSL: Multiple vulnerabilities
Bugs: #543552


Multiple vulnerabilities have been found in OpenSSL that can result in either Denial of Service or information disclosure.


OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general purpose cryptography library.

Affected packages

Package Vulnerable Unaffected Architecture(s)
dev-libs/openssl < 1.0.1l-r1 >= 1.0.1l-r1 All supported architectures


Multiple vulnerabilities have been found in OpenSSL. Please review the CVE identifiers and the upstream advisory referenced below for details:

  • RSA silently downgrades to EXPORT_RSA [Client] (Reclassified) (CVE-2015-0204)
  • Segmentation fault in ASN1_TYPE_cmp (CVE-2015-0286)
  • ASN.1 structure reuse memory corruption (CVE-2015-0287)
  • X509_to_X509_REQ NULL pointer deref (CVE-2015-0288)
  • PKCS7 NULL pointer dereferences (CVE-2015-0289)
  • Base64 decode (CVE-2015-0292)
  • DoS via reachable assert in SSLv2 servers (CVE-2015-0293)
  • Use After Free following d2i_ECPrivatekey error (CVE-2015-0209)

The following issues affect OpenSSL 1.0.2 only which is not part of the supported Gentoo stable tree:

  • OpenSSL 1.0.2 ClientHello sigalgs DoS (CVE-2015-0291)
  • Multiblock corrupted pointer (CVE-2015-0290)
  • Segmentation fault in DTLSv1_listen (CVE-2015-0207)
  • Segmentation fault for invalid PSS parameters (CVE-2015-0208)
  • Empty CKE with client auth and DHE (CVE-2015-1787)
  • Handshake with unseeded PRNG (CVE-2015-0285)


A remote attacker can utilize multiple vectors to cause Denial of Service or Information Disclosure.


There is no known workaround at this time.


All OpenSSL 1.0.1 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1l-r1"

All OpenSSL 0.9.8 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.8z_p5-r1"

Packages which depend on the OpenSSL library need to be restarted for the upgrade to take effect. Some packages may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!