GLSA 201203-10: libmikmod: User-assisted execution of arbitrary code

Title:libmikmod: User-assisted execution of arbitrary code
Bugs: #335892


Multiple buffer overflow vulnerabilities in libmikmod may allow an attacker to execute arbitrary code or cause a Denial of Service condition.


libmikmod is a library to play a wide range of module formats.

Affected packages

Package Vulnerable Unaffected Architecture(s)
media-libs/libmikmod < 3.2.0_beta2-r3 >= 3.2.0_beta2-r3 All supported architectures


Multiple boundary errors have been found in load_it.c in libmikmod, which may cause a buffer overflow.


A remote attacker could entice a user to open specially crafted files in an application linked against libmikmod, possibly resulting in execution of arbitrary code with the permissions of the user running the application, or Denial of Service.


There is no known workaround at this time.


All libmikmod 3.2 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose

All libmikmod 3.1 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libmikmod-3.1.12-r1"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!