GLSA 201411-04: PHP: Multiple vulnerabilities

Title:PHP: Multiple vulnerabilities
Bugs: #525960


Multiple vulnerabilities have been discovered in PHP, the worst of which could lead to remote execution of arbitrary code.


PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected packages

Package Vulnerable Unaffected Architecture(s)
dev-lang/php < 5.5.18 >= 5.5.18 All supported architectures


Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.


A context-dependent attacker can possibly execute arbitrary code or create a Denial of Service condition.


There is no known workaround at this time.


All PHP 5.5 users should upgrade to the latest version:

      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.18"

All PHP 5.4 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.34"

All PHP 5.3 users should upgrade to the latest version. This release marks the end of life of the PHP 5.3 series. Future releases of this series are not planned. All PHP 5.3 users are encouraged to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.3.29"



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!