GLSA 200602-04: Xpdf, Poppler: Heap overflow

Title:Xpdf, Poppler: Heap overflow
Bugs: #120985


Xpdf and Poppler are vulnerable to a heap overflow that may be exploited to execute arbitrary code.


Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base.

Affected packages

Package Vulnerable Unaffected Architecture(s)
app-text/xpdf < 3.01-r7 >= 3.01-r7 All supported architectures
app-text/poppler < 0.5.0-r4 >= 0.5.0-r4 All supported architectures


Dirk Mueller has reported a vulnerability in Xpdf. It is caused by a missing boundary check in the splash rasterizer engine when handling PDF splash images with overly large dimensions.


By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.


There is no known workaround at this time.


All Xpdf users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r7"

All Poppler users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=app-text/poppler-0.5.0-r4"



This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2010 Gentoo Foundation, Inc; referenced text belongs to its owner(s). The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

Thank you!