cherokee

Description:An extremely fast and tiny web server
License: GPL-2
Homepage:http://www.cherokee-project.com/
Location:Portage
Legend:
  • + - stable
  • ~ - unstable
  • M - hardmask
alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86
1.2.104-r1 - ~ ~ - - - ~ ~ ~ - - - ~

USE flags

  • admin - Install web based cherokee conf tool
  • debug - Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
  • fastcgi - Add support for the FastCGI interface
  • ffmpeg - Enable ffmpeg/libav-based audio/video codec support
  • geoip - Add geoip support for country and city lookup based on IPs
  • ipv6 - Add support for IP version 6
  • kernel_linux - KERNEL setting for system using the Linux kernel
  • ldap - Add LDAP support (Lightweight Directory Access Protocol)
  • libressl - Use dev-libs/libressl instead of dev-libs/openssl when applicable (see also the ssl useflag)
  • mysql - Add mySQL Database support
  • nls - Add Native Language Support (using gettext - GNU locale utilities)
  • pam - Add support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
  • php - Include support for the PHP language
  • python_targets_python2_6 - Build with Python 2.6 (removed)
  • python_targets_python2_7 - Build with Python 2.7
  • rrdtool - Enable rrdtool support
  • ssl - Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
  • static - !!do not set this during bootstrap!! Causes binaries to be statically linked instead of dynamically
  • static-libs - Build static versions of dynamic libraries as well
  • threads - Add threads support for various packages. Usually pthreads

Security Advisory

Date Severity Title
almost 15 years high Cherokee: Format string vulnerability

Also available in: Atom

Thank you!