Diff gpodder-3.9.1 with a gpodder-3.10.5

/usr/portage/media-sound/gpodder/gpodder-3.10.5.ebuild 2018-11-11 19:39:00.000000000 +0300
1
# Copyright 1999-2016 Gentoo Foundation
1
# Copyright 1999-2018 Gentoo Authors
2 2
# Distributed under the terms of the GNU General Public License v2
3 3

  
4 4
EAPI=6
5
PYTHON_COMPAT=( python2_7 )
5
PYTHON_COMPAT=( python3_{6,7} )
6 6
PYTHON_REQ_USE="sqlite"
7
# Required for python_fix_shebang:
8 7
DISTUTILS_SINGLE_IMPL=1
9 8

  
10 9
inherit distutils-r1 gnome2-utils
11 10

  
12 11
DESCRIPTION="A free cross-platform podcast aggregator"
13
HOMEPAGE="http://gpodder.org/"
14
SRC_URI="http://gpodder.org/src/${P}.tar.gz"
12
HOMEPAGE="https://gpodder.github.io/"
13
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15 14

  
16 15
LICENSE="GPL-3"
17 16
SLOT="0"
18 17
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
19
IUSE="+dbus bluetooth ipod kernel_linux mtp test"
18
IUSE="+dbus bluetooth kernel_linux mtp test"
20 19

  
21
#TODO: Make pygtk optional, see README
20
# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_USEDEP}] and
21
# ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] ) once they
22
# support python3
22 23
COMMON_DEPEND="
23
	>=dev-python/eyeD3-0.7
24
	>=dev-python/feedparser-5.1.2
25
	dev-python/html5lib
26
	>=dev-python/mygpoclient-1.7
27
	>=dev-python/pygtk-2.16:2
28
	dbus? ( dev-python/dbus-python )
24
	dev-python/html5lib[${PYTHON_USEDEP}]
25
	dev-python/isort[${PYTHON_USEDEP}]
26
	dev-python/pycairo[${PYTHON_USEDEP}]
27
	>=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
28
	>=dev-python/podcastparser-0.6.0[${PYTHON_USEDEP}]
29
	>=dev-python/mygpoclient-1.8[${PYTHON_USEDEP}]
30
	dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
29 31
	bluetooth? ( net-wireless/bluez )
30
	ipod? ( media-libs/libgpod[python] )
31 32
	mtp? ( >=media-libs/libmtp-1.0.0:= )
32 33
"
33 34
RDEPEND="${COMMON_DEPEND}
......
43 44
	)
44 45
"
45 46

  
46
src_prepare() {
47
	default
48
	sed -i -e '/setup.py.*install/d' makefile || die
49
	# Fix for "AttributeError: 'gPodder' object has no attribute 'toolbar'":
50
	python_fix_shebang .
51
}
52

  
53 47
src_install() {
54
	emake DESTDIR="${D}" install
48
	emake PYTHON=python3 DESTDIR="${D}" install
55 49
	distutils-r1_src_install
56 50
}
57 51

  
Thank you!