Diff libtgvoip-2.4.4_p20210302 with a libtgvoip-2.4.4_p20210302-r1

/usr/portage/media-libs/libtgvoip/libtgvoip-2.4.4_p20210302-r1.ebuild 2021-06-12 04:39:00.000000000 +0300
14 14
LICENSE="Unlicense"
15 15
SLOT="0"
16 16
KEYWORDS="amd64 ~ppc64"
17
IUSE="+dsp pulseaudio"
17
IUSE="+dsp +alsa pulseaudio"
18 18

  
19 19
DEPEND="
20
	dev-libs/openssl:0=
21 20
	media-libs/opus:=
22
	media-libs/alsa-lib
23
	!pulseaudio? ( media-sound/apulse[sdk] )
24
	pulseaudio? ( media-sound/pulseaudio )
21
	alsa? ( media-libs/alsa-lib )
25 22
	dsp? ( media-libs/tg_owt )
23
	pulseaudio? ( media-sound/pulseaudio )
26 24
"
27 25
RDEPEND="${DEPEND}"
28 26
BDEPEND="virtual/pkgconfig"
27
REQUIRED_USE="
28
	|| ( alsa pulseaudio )
29
"
29 30

  
30 31
S="${WORKDIR}/${PN}-${LIBTGVOIP_COMMIT}"
31 32

  
......
41 42
src_configure() {
42 43
	local myconf=(
43 44
		--disable-static
44
		--with-alsa
45
		--with-pulse
46 45
		--disable-dsp  # WebRTC is linked from tg_owt
46
		$(use_with alsa)
47
		$(use_with pulseaudio pulse)
47 48
	)
48
	append-cppflags '-DNDEBUG'
49 49
	if use dsp; then
50 50
		append-cppflags '-I/usr/include/tg_owt'
51 51
		append-cppflags '-I/usr/include/tg_owt/third_party/abseil-cpp'
Thank you!