Diff sass-3.4.25-r1 with a sass-3.5.7

/usr/portage/dev-ruby/sass/sass-3.5.7.ebuild 2020-01-13 09:39:00.000000000 +0300
3 3

  
4 4
EAPI=6
5 5

  
6
USE_RUBY="ruby24 ruby25 ruby26"
6
USE_RUBY="ruby23 ruby24 ruby25 ruby26"
7 7

  
8 8
RUBY_FAKEGEM_TASK_DOC=""
9 9
RUBY_FAKEGEM_DOCDIR="doc"
10 10
RUBY_FAKEGEM_EXTRADOC="README.md"
11 11

  
12
RUBY_FAKEGEM_EXTRAINSTALL="rails init.rb VERSION VERSION_NAME"
12
RUBY_FAKEGEM_EXTRAINSTALL="rails init.rb VERSION VERSION_DATE VERSION_NAME"
13 13

  
14
# Allow the latest slot to provide these
15
RUBY_FAKEGEM_BINWRAP=""
16

  
17
inherit ruby-fakegem versionator
14
inherit ruby-fakegem eapi7-ver
18 15

  
19 16
DESCRIPTION="An extension of CSS3, adding nested rules, variables, mixins, and more"
20
HOMEPAGE="http://sass-lang.com/"
17
HOMEPAGE="https://sass-lang.com/"
21 18
LICENSE="MIT"
22 19

  
23
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
24
SLOT="$(get_version_component_range 1-2)"
20
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
21
SLOT="$(ver_cut 1-2)"
25 22
IUSE=""
26 23

  
27 24
ruby_add_bdepend "doc? ( >=dev-ruby/yard-0.5.3 )"
28 25

  
29
ruby_add_rdepend ">=dev-ruby/listen-1.3.1:1"
26
ruby_add_rdepend "
27
	!!<dev-ruby/sass-3.4.25-r1:3.4
28
	dev-ruby/sass-listen:4"
30 29

  
31 30
# tests could use `less` if we had it
32 31

  
33 32
all_ruby_prepare() {
34
	rm -rf vendor/listen || die
35

  
36 33
	# Don't require maruku as markdown provider but let yard decide.
37 34
	sed -i -e '/maruku/d' .yardopts || die
35

  
36
	# Keep VERSION_DATE around since we don't create a new package
37
	sed -i -e '/at_exit/,/end/ s:^:#:' Rakefile || die
38 38
}
39 39

  
40 40
each_ruby_test() {
Thank you!