Diff mocha-0.14.0-r1 with a mocha-1.8.0

/usr/portage/dev-ruby/mocha/mocha-1.8.0.ebuild 2020-12-15 06:09:00.000000000 +0300
1
# Copyright 1999-2021 Gentoo Authors
1
# Copyright 1999-2020 Gentoo Authors
2 2
# Distributed under the terms of the GNU General Public License v2
3 3

  
4
EAPI=7
5
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
4
EAPI=6
5
USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6 6

  
7
RUBY_FAKEGEM_TASK_TEST="MOCHA_NO_DOCS=true test:units"
7
RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
8 8

  
9
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
9 10
RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
10 11

  
11 12
RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
......
13 14
inherit ruby-fakegem
14 15

  
15 16
DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
16
HOMEPAGE="http://gofreerange.com/mocha/docs/"
17
HOMEPAGE="https://mocha.jamesmead.org/"
17 18

  
18 19
LICENSE="MIT"
19
SLOT="0.14"
20
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
20
SLOT="1.0"
21
KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
21 22
IUSE=""
22 23

  
23 24
ruby_add_bdepend "
24 25
	test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
25 26

  
26
ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
27
ruby_add_rdepend "=dev-ruby/metaclass-0.0*"
27 28

  
28 29
all_ruby_prepare() {
29 30
	sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
30
	sed -i -e '20irequire "mocha/setup"' test/test_helper.rb || die
31
}
32

  
33
each_ruby_test() {
34
	export MOCHA_NO_DOCS=true
35
	each_fakegem_test
31 36
}
Thank you!