Diff contextlib2-0.5.5 with a contextlib2-0.6.0

/usr/portage/dev-python/contextlib2/contextlib2-0.6.0.ebuild 2020-01-05 14:15:00.000000000 +0300
1 1
# Copyright 1999-2020 Gentoo Authors
2 2
# Distributed under the terms of the GNU General Public License v2
3 3

  
4
EAPI=6
4
EAPI=7
5 5

  
6
PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
6
PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
7 7

  
8 8
inherit distutils-r1
9 9

  
......
13 13

  
14 14
LICENSE="PSF-2.4"
15 15
SLOT="0"
16
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86"
16
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
17 17
IUSE="test"
18 18

  
19 19
DEPEND="
20 20
	dev-python/setuptools[${PYTHON_USEDEP}]
21
	test? ( dev-python/unittest2[${PYTHON_USEDEP}] )
21
	test? ( $(python_gen_cond_dep '
22
			dev-python/unittest2[${PYTHON_USEDEP}]
23
			' python{2_7,3_{5,3,6,7}} pypy{,3}
24
		)
25
	)
22 26
"
27

  
23 28
RESTRICT="!test? ( test )"
24 29

  
30
python_prepare_all() {
31
	sed -i -e 's:unittest.main():unittest.main(verbosity=2):' \
32
		test_contextlib2.py || die
33

  
34
	distutils-r1_python_prepare_all
35
}
36

  
25 37
python_test() {
26 38
	"${PYTHON}" test_contextlib2.py || die "Tests fail for ${EPYTHON}"
27 39
}
Thank you!