Diff libgcrypt-1.8.3 with a libgcrypt-1.8.3-r1

/usr/portage/dev-libs/libgcrypt/libgcrypt-1.8.3-r1.ebuild 2019-10-11 18:40:00.000000000 +0300
1
# Copyright 1999-2018 Gentoo Foundation
1
# Copyright 1999-2018 Gentoo Authors
2 2
# Distributed under the terms of the GNU General Public License v2
3 3

  
4
EAPI=6
4
EAPI=7
5 5

  
6
inherit autotools flag-o-matic ltprune multilib-minimal
6
inherit autotools flag-o-matic multilib-minimal
7 7

  
8 8
DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
9 9
HOMEPAGE="http://www.gnupg.org/"
......
11 11

  
12 12
LICENSE="LGPL-2.1 MIT"
13 13
SLOT="0/20" # subslot = soname major version
14
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 15
IUSE="doc o-flag-munging static-libs"
16 16

  
17 17
RDEPEND=">=dev-libs/libgpg-error-1.25[${MULTILIB_USEDEP}]"
18
DEPEND="${RDEPEND}
19
	doc? ( virtual/texi2dvi )"
18
DEPEND="${RDEPEND}"
19
BDEPEND="doc? ( virtual/texi2dvi )"
20 20

  
21 21
PATCHES=(
22 22
	"${FILESDIR}"/${PN}-1.6.1-uscore.patch
......
56 56

  
57 57
		GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config"
58 58
	)
59
	ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
59
	ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" \
60
		$("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
60 61
}
61 62

  
62 63
multilib_src_compile() {
......
71 72

  
72 73
multilib_src_install_all() {
73 74
	default
74
	prune_libtool_files
75
	find "${D}" -name '*.la' -delete || die
75 76
}
Thank you!