Diff pet-0.3.6 with a pet-0.3.6-r1

/usr/portage/app-misc/pet/pet-0.3.6-r1.ebuild 2020-06-06 20:08:00.000000000 +0300
1
# Copyright 1999-2019 Gentoo Authors
1
# Copyright 1999-2020 Gentoo Authors
2 2
# Distributed under the terms of the GNU General Public License v2
3 3

  
4 4
EAPI=7
5
inherit go-module
6 5

  
7
DESCRIPTION="Simple command-line snippet manager"
8
HOMEPAGE="https://github.com/knqyf263/pet"
6
inherit go-module
9 7

  
10 8
EGO_SUM=(
11 9
	"github.com/BurntSushi/toml v0.3.0"
......
54 52
	"google.golang.org/appengine v1.0.0/go.mod"
55 53
	)
56 54
go-module_set_globals
55

  
56
DESCRIPTION="Simple command-line snippet manager"
57
HOMEPAGE="https://github.com/knqyf263/pet"
57 58
SRC_URI="https://github.com/knqyf263/pet/archive/v${PV}.tar.gz -> ${P}.tar.gz
58 59
	${EGO_SUM_SRC_URI}"
59 60

  
60 61
LICENSE="Apache-2.0 BSD BSD-2 MIT"
61 62
SLOT="0"
62 63
KEYWORDS="~amd64"
64
IUSE=""
63 65

  
64 66
src_compile() {
65
	go build || die
67
	go build || die "build failed"
68
}
69

  
70
src_test() {
71
	go test -work || die "test failed"
66 72
}
67 73

  
68 74
src_install() {
......
72 78
}
73 79

  
74 80
pkg_postinst() {
75
	if ! has_version app-shells/peco ; then
76
		einfo "You should consider to install app-shells/peco"
77
		einfo "to be able to use selector command"
81
	go-module_pkg_postinst
82

  
83
	if ! has_version app-shells/peco && ! has_version app-shells/fzf ; then
84
		einfo "You should consider to install app-shells/peco or"
85
		einfo "app-shells/fzf to be able to use selector command"
78 86
	fi
79 87
}
Thank you!