обновлений НЕТ ?

Added by Иван Нессуть 4 months ago

насколько я понял из описания доки .. тут нет обновлений .. тут есть НЕЧТО что сносит всю ситему и ставить текущее ? типа самое последнее ?

и типа если долго работал .. и обновление не обновляет а падает .. вариант только один снос системы и переустановка ???

и доустановить что либо уже не получится ? допустим старую самбу или старых хром ? потому что надо снести всю систему и поставить новую последнюю ??
тогда ты сможешь доставить пакет ?


Replies (43)

RE: обновлений НЕТ ? - Added by Виктор Кустов 4 months ago

Иван Нессуть wrote:

или вы думаете что поставил систему и дежурю около её чтоли ?

тем более раз рабочая и работает - ssh и удалённый доступ рулят.

ребята она РАБОТАЕТ !!!!

дык и я про то же ;-)

RE: обновлений НЕТ ? - Added by Виктор Кустов 4 months ago

Иван Нессуть wrote:

спасибо за ссылку на архивы .. по возможности побробуем провести эксперимент !

если эксперимент подразумевает установку старого софта - можно не беспокоиться. софт берётся из репозитария и старых версий там нет.

я бы всё же настоятельно рекомендовал обновиться-таки, несмотря на то, что придётся немного повникать в суть проблем.

RE: обновлений НЕТ ? - Added by Denis J 4 months ago

Иван Нессуть wrote:

насколько я понял из описания доки .. тут нет обновлений .. тут есть НЕЧТО что сносит всю ситему и ставить текущее ? типа самое последнее ?

Rolling release

и типа если долго работал .. и обновление не обновляет а падает .. вариант только один снос системы и переустановка ???

Нет но надо понимать что делаеш и зачем

старую самбу или старых хром ?

Calculate Rolling release
Если зачем то надо старые версии надо писать свой ebuild
или искать тут

я бы всё же настоятельно рекомендовал обновиться-таки, несмотря на то, что придётся немного повникать в суть проблем.

на 15 еще профиль 13 отвалится что угодно может

RE: обновлений НЕТ ? - Added by Иван Нессуть 4 months ago

Denis J wrote:

обновить хромикум - оказывается перестановка системы только !

Тут телепатов нету вывод команд сделайте


[...]


и ссылки сюда выложите

emerge --info | wgetpaste
http://pastebin.calculate-linux.ru/ru/show/95636

emerge -pvuDN @world | wgetpaste
выдает партянку и ссылку

e

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/zlib:0

  (sys-libs/zlib-1.2.11-r2:0/1::gentoo, binary scheduled for merge) pulled in by
    sys-libs/zlib:0/1= required by (sys-apps/util-linux-2.33-r1:0/0::gentoo, binary scheduled for merge)
                 ^^^^^                                                                                                                      
    (and 5 more with the same problem)

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.8-r1:0/0=[abi_x86_32(-)] required by (media-libs/tiff-4.0.6:0/0::gentoo, installed)
                            ^^^^^                                                                                                              

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

!!! All ebuilds that could satisfy ">=dev-libs/nspr-4.13.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/nspr-4.20::gentoo (masked by: EAPI 7)
- dev-libs/nspr-4.20 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-lang/spidermonkey-52.9.1_pre1::gentoo" [binary])
(dependency required by "sys-auth/polkit-0.115-r2::gentoo" [binary])
(dependency required by "sys-auth/consolekit-1.2.1::gentoo" [binary])
(dependency required by "sys-auth/pambase-20150213-r1::gentoo[consolekit]" [ebuild])
(dependency required by "sys-libs/pam-1.3.0-r2::gentoo" [binary])
(dependency required by "sys-apps/util-linux-2.33-r1::gentoo" [binary])
(dependency required by "media-libs/fontconfig-2.13.0-r4::gentoo" [binary])
(dependency required by "x11-libs/cairo-1.16.0-r2::gentoo" [binary])
(dependency required by "dev-libs/gobject-introspection-1.56.1::gentoo" [binary])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

!!! Invalid news item: /usr/portage/metadata/news/2017-10-10-perl-5_26-update/2017-10-10-perl-5_26-update.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-14-gnucash/2018-01-14-gnucash.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-11-30-new-17-profiles/2017-11-30-new-17-profiles.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-30-portage-rsync-verification/2018-01-30-portage-rsync-verification.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-23-systemd-blocker/2018-01-23-systemd-blocker.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-07-11-portage-sync-allow-hardlinks/2018-07-11-portage-sync-allow-hardlinks.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-03-13-portage-rsync-verification-unstable/2018-03-13-portage-rsync-verification-unstable.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-05-22-python3-6/2018-05-22-python3-6.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-11-21-old-wine-versions-moving-to-overlay/2017-11-21-old-wine-versions-moving-to-overlay.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!!   line 6: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-12-26-experimental-amd64-17-1-profiles/2017-12-26-experimental-amd64-17-1-profiles.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-04-08-radicale-2-requires-pre-install-migration/2018-04-08-radicale-2-requires-pre-install-migration.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-08-07-openssh-ldap-migration/2018-08-07-openssh-ldap-migration.en.txt
!!!   line 5: News-Item-Format: 2.0
enconv: Cannot convert `/tmp/wgetpaste.Z5oXbh' from unknown encoding
Your paste can be seen here: http://pastebin.calculate-linux.ru/ru/show/95640


http://pastebin.calculate-linux.ru/ru/show/95640

RE: обновлений НЕТ ? - Added by Denis J 4 months ago

Иван Нессуть wrote:

The current version of portage supports EAPI '6'. You must upgrade to a newer version of portage before EAPI masked packages can be installed.

тут ругается на старую версию portage надо обновить

 emerge -1 portage

после обновления опять пробовать обновится и смотреть выхлоп emerge

RE: обновлений НЕТ ? - Added by Иван Нессуть 4 months ago

Denis J wrote:

Иван Нессуть wrote:


The current version of portage supports EAPI '6'. You must upgrade to a newer version of portage before EAPI masked packages can be installed.

тут ругается на старую версию portage надо обновить


[...]


после обновления опять пробовать обновится и смотреть выхлоп emerge

делал уже но без еденички
после вашей .. все тоже самое ..

emerge -avuDN @world
!!! Invalid news item: /usr/portage/metadata/news/2017-10-10-perl-5_26-update/2017-10-10-perl-5_26-update.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-14-gnucash/2018-01-14-gnucash.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-11-30-new-17-profiles/2017-11-30-new-17-profiles.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-30-portage-rsync-verification/2018-01-30-portage-rsync-verification.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-01-23-systemd-blocker/2018-01-23-systemd-blocker.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-07-11-portage-sync-allow-hardlinks/2018-07-11-portage-sync-allow-hardlinks.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-03-13-portage-rsync-verification-unstable/2018-03-13-portage-rsync-verification-unstable.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-05-22-python3-6/2018-05-22-python3-6.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-11-21-old-wine-versions-moving-to-overlay/2017-11-21-old-wine-versions-moving-to-overlay.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!!   line 6: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-12-26-experimental-amd64-17-1-profiles/2017-12-26-experimental-amd64-17-1-profiles.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-04-08-radicale-2-requires-pre-install-migration/2018-04-08-radicale-2-requires-pre-install-migration.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2018-08-07-openssh-ldap-migration/2018-08-07-openssh-ldap-migration.en.txt                   
!!!   line 5: News-Item-Format: 2.0                                                                                                            

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.                                                                               
 * Use eselect news read to view new items.                                                                                                    

These are the packages that would be merged, in order:                                                                                         

Calculating dependencies... done!                                                                                                              

!!! Multiple package instances within a single package slot have been pulled                                                                   
!!! into the dependency graph, resulting in a slot conflict:                                                                                   

sys-libs/zlib:0                                                                                                                                

  (sys-libs/zlib-1.2.11-r2:0/1::gentoo, binary scheduled for merge) pulled in by                                                               
    >=sys-libs/zlib-1.2.8-r1:0/1=[abi_x86_32(-)] required by (x11-libs/libpciaccess-0.14:0/0::gentoo, binary scheduled for merge)              
                            ^^^^^                                                                                                                                    
    (and 6 more with the same problem)

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.8-r1:0/0=[abi_x86_32(-)] required by (media-libs/tiff-4.0.6:0/0::gentoo, installed)
                            ^^^^^                                                                                                              

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

!!! All ebuilds that could satisfy ">=dev-libs/nspr-4.13.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/nspr-4.20::gentoo (masked by: EAPI 7)
- dev-libs/nspr-4.20 (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-lang/spidermonkey-52.9.1_pre1::gentoo" [ebuild])
(dependency required by "sys-auth/polkit-0.115-r2::gentoo" [binary])
(dependency required by "sys-auth/consolekit-1.2.1::gentoo" [binary])
(dependency required by "sys-auth/pambase-20150213-r1::gentoo[consolekit]" [ebuild])
(dependency required by "sys-libs/pam-1.3.0-r2::gentoo" [binary])
(dependency required by "sys-apps/util-linux-2.33-r1::gentoo" [binary])
(dependency required by "media-libs/fontconfig-2.13.0-r4::gentoo" [binary])
(dependency required by "media-libs/gd-2.2.5-r1::gentoo" [binary])
(dependency required by "sys-libs/glibc-2.27-r6::gentoo" [binary])
(dependency required by "sys-devel/gcc-7.3.0-r3::gentoo" [binary])
(dependency required by "@system" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

если про выхлоп имелось

emerge --info | wgetpaste
Your paste can be seen here: http://pastebin.calculate-linux.ru/ru/show/95654

прилагаю ..

RE: обновлений НЕТ ? - Added by Denis J 4 months ago

Поставил на старую железку CLDM-15-17 .
Циклические блокировки чтоб ставить пакеты надо последний portage
чтоб поставить portage надо обновить dev-lang/python
чтоб обновить dev-lang/python надо пересобрать Toolchain
А чтоб пересобрать Toolchain надо новый portage .

Если несколько дней покопатся может что то и получится.

Быстрее будет сделать бэкап нужных файлов и переустановить систему

И еще там профиль 13 но я хз как на calculate на 17 перейти

Без последнего portage ни один пакет не поставить

RE: обновлений НЕТ ? - Added by Denis J 4 months ago

Можно попробовать поставить портаже принудительно

emerge -O portage

но это будет костыль и все может поломаться

RE: обновлений НЕТ ? - Added by Иван Нессуть 3 months ago

что все ? все идеи кончлись ?
кто тут просил детали ??? о великие верующие в обновление калкулейт линукса ?

RE: обновлений НЕТ ? - Added by Denis J 3 months ago

если есть желание возиться с обновлением то надо
обновить portage
обновить python
обновить gcc libtool glibc binutils
обновить system и world

Мое IMHO быстрее поставить заново и не городить ведосипеды

ЗЫ и еще все зависимости разрулить ручками придется

RE: обновлений НЕТ ? - Added by Денис Терехов 3 months ago

Иван Нессуть wrote:

что все ? все идеи кончлись ?
кто тут просил детали ??? о великие верующие в обновление калкулейт линукса ?

Вот именно для такого и придумали второй корневой раздел.
И не надо кидаться какашками, это именно Ваша вина, что Вы не вникли, не почитали документацию перед установкой системы, это Вы довели ее до такого состояния. А теперь требуете чего-то от других.
У Вас выход - сохранять конфиги и ставить заново. И сделать второй корень.

RE: обновлений НЕТ ? - Added by Denis J 3 months ago

Денис Терехов wrote:

Вот именно для такого и придумали второй корневой раздел.

2 раздел нужен только чтоб LFS в chroote курочить для домашнего пользователя он даром не надо.

А по делу старые версии ebuild-ов в теории можно с помощью git откатить

RE: обновлений НЕТ ? - Added by Alexander Tratsevskiy 3 months ago

2 раздел нужен только чтоб LFS в chroote курочить для домашнего пользователя он даром не надо.

Как сказать, на англ. форуме как раз сейчас человек пишет, что решил систему обновить спустя 2 года, наткнулся на проблемы. Был бы второй раздел, можно было бы качнуть образ и выполнить cl-install без параметров не записывая на флешку. Пользователи, настройки, данные и разделы - все переносится в новую систему. При этом всегда остаётся предыдущая установленная версия.

RE: обновлений НЕТ ? - Added by Denis J 3 months ago

Как сказать, на англ. форуме как раз сейчас человек пишет, что решил систему обновить спустя 2 года, наткнулся на проблемы.

Обновлять Rolling release с образа стоит только если трафик дорогой или политиками организации запрещено.

А что годами не обновляют систему надо в документации ссылку на википедию оставить про Rolling release.

RE: обновлений НЕТ ? - Added by Denis J 3 months ago

И никто не мешает переразбить раздел и использовать его для обновления

RE: обновлений НЕТ ? - Added by Денис Терехов 3 months ago

Denis J wrote:

Денис Терехов wrote:


Вот именно для такого и придумали второй корневой раздел.

2 раздел нужен только чтоб LFS в chroote курочить для домашнего пользователя он даром не надо.


А по делу старые версии ebuild-ов в теории можно с помощью git откатить

Вы оооочень сильно неправы. У меня Калька стоит на домашнем нетбуке.
Вы почему-то вместо простой и прямой дороги выбираете узкую извилистую тропинку через бурелом.

RE: обновлений НЕТ ? - Added by Denis J 3 months ago

у меня тоже калька только на нетбуке. Но ТС очень хочет именно обновить . Я несколько раз предлагал переустановить систему.

RE: обновлений НЕТ ? - Added by Alexander Tratsevskiy 3 months ago

Обновлять Rolling release с образа стоит только если трафик дорогой или политиками организации запрещено.

У нас в организации вот уже 12 лет калька обновляется из образа, чему мы все очень рады. Запрета разумеется никакого нет. Из преимуществ - скорость и стабильность. Когда всё правильно настроено, то обновления происходят без участия системного администратора при перезагрузке системы. Пользователь приходит с утра и начинает работать уже в новой системе. Недавно добавили поддержку переноса ПО, совсем стало хорошо, до этого использовали всегда только базовый набор ПО из коробки.

« Previous 1 2 (26-43/43)

Thank you!